are the OBS repos for darktable dead?

I’ve extended the signkey and triggered a new build.

1 Like

Thanks a lot Andreas ! Now it works again.

Hmm, I’m have the same problem again, with my update manager complaining that the signing key is invalid :frowning:
I’ve tried deleting the key and repository and manually adding them again as described above, but no luck.
Linux Mint 20.3 (Ubuntu 20.04).
Does anybody else see this or is the problem on my end?

I’m on the master OBS (so darktable v3.9) and it’s working fine on Ubuntu 20.04.

you need to reimport the key as already mentioned in the thread.

Yep, did that, but I’m still getting the same error message.

I believe the problem is that for the darktable releases at:
(i.e the “latest release” repository) doesn’t have an apt-repo for Ubuntu 20.04 LTS but only for 22.04 LTS and 21.04 & 21.10.

Ubuntu 20.04 LTS is still supported by Canonical until April 2025, so almost three more years and the upgrade path 20.04 → 22.04 will only open for all users sometimes in August.

The other two have builds for Ubuntu 20.04:

Maybe @asn can have a look at the configs. The build of 3.8.x for Ubuntu 20.04 used to work after all.

I had the same problem just a few days ago, and I then realized that the key for the darktable’s OBS repo was in a couple of places in /etc/apt: inside the deprecated trusted.gpg file, and in two different files in the trusted.d folder. Reimporting the key overwrote one of them (or even created a new one!), but apt still respected the expiration date of the other versions. Reimporting only worked after I deleted all versions of the key.

This was on Kubuntu 22.04

1 Like

Right. The second command for installing the OBS repos is:

curl -fsSL | gpg --dearmor | sudo tee /etc/apt/trusted.gpg.d/graphics_darktable.gpg > /dev/null

which (over-)writes the keyfile to: etc/apt/trusted.gpg.d/graphics_darktable.gpg

I typically deviate from those instructions and install the key using sudo apt-key add Release.key .
Having the old (expired) key in the keychain won’t hurt, as long as the new (valid) key is present.

But I still get errors b/c I’m running Ubuntu 20.04 and only install official dt releases, but that repo has disappeared.
Right now I don’t mind b/c I had already installed the 3.8.1 release before the key was changed and the repo disappeared.

For you on *buntu 22.04, you can also use the darktable-3.8.1 that is available in the canonical deb-repos.
I haven’t tested it yet myself, so I don’t know if it has all the bells and whistles (CR3, lua and other features that depend on external factors).

I’d have expected the same, but it was not the case. For some reason apt was still picking the expired version of the key, even if a valid one was there.

Yes, but then I’d be back at the OBS when 4.0 is released, so I prefer to stick to one repo.

Thanks, that may very well be the case.
I’ll try tomorrow and report back :blush::+1:

This was it!
I deleted the old keys in /etc/apt/trusted.gpg.d and I’m back on the master snapshots :slight_smile:
Thanks a lot :slight_smile:

FYI, there seems to be errors now compiling dt in obs for some distros…

For which distro?

Maybe this is not the same problem, but I don’t get any updates since a few days. I use master version of the darktable with Kubuntu 20.04

However, there are no error messages either.

I was told 20.04 builds do not have the requisite dependencies anymore.

It seems all debian and ubuntu versions.

build errors → no new updated packages

Those errors seems strange tho, as it would look for old version:
dpkg-source: error: can’t build with source format ‘3.0 (quilt)’: no upstream tarball found at …/darktable_2.4.0~rc2.orig.tar.{bz2,gz,lzma,xz}

please can someone help me. I’m on Linux Mint 20.3 and I get the following messages with apt-get update:

Fehl:11  InRelease
  Die folgenden Signaturen waren ungültig: EXPKEYSIG 040524A84C70D8B5 graphics:darktable OBS Project <>
W: GPG-Fehler:  InRelease: Die folgenden Signaturen waren ungültig: EXPKEYSIG 040524A84C70D8B5 graphics:darktable OBS Project <>
E: Das Depot »  InRelease« ist nicht signiert.
N: Eine Aktualisierung von solch einem Depot kann nicht auf eine sichere Art durchgeführt werden, daher ist es standardmäßig deaktiviert.
N: Weitere Details zur Erzeugung von Paketdepots sowie zu deren Benutzerkonfiguration finden Sie in der Handbuchseite apt-secure(8).

I already changed the source-list to this:

deb /

Because the URL changed I guess. Then reimported the key. But I still get this message.

I don’t understand this thing enough to fix it. So is there a way? Or if not is there another way to install the stable release of darktable on linux mint. I could also upgrade to a newer version of mint if that’s an option.

Thanks in advance.


You need to remove the old key.

Ok, thank you. I think I removed them. I deleted a file in /etc/apt and /etc/apt/trusted.gpg.d. I get the same messages. Do I need to import a new key? How?