Call for testing: RawTherapee 5.4-rc2


(Carmelo Dr Raw) #21

@agriggio @Morgan_Hardwood - I installed the CLUTs and restarted RT, but I still had to select the CLUT manually after loading the .PP3 file. After exporting the result, the new .PP3 shows

[Film Simulation]
Enabled=true
ClutFilename=Fujifilm XTrans III/Fuji XTrans III - Acros+G.png
Strength=100

So there seems to be some path delimiter issue when exchanging files between Windows and *nix. Should I open a new issue?


(Morgan Hardwood) #22

@Carmelo_DrRaw please do.


#23

Call for testing; here is my reply! :grin:

First of all: good work guys (girls?). Since 5.3 a lot of fine tuning seems to be done.
I’ve been clicking around with Branch: 5.4-rc2/Commit: 042c49d34 and at first glance everything seems to be working fine. No crashes so far.

Some remarks:
-As regarding to the RT speed on my Win64-bit system (i7 980X @ 4GHz, 24GB RAM + R9 270x GPU). Startup time is fast (about 2 seconds). Preferences window opens almost instantaneously.
-Conversion speed while processing D800E NEF (RAW files) --> 8bit TIFF files (each about 106Mb); it takes about 10 minutes to process 100 files.
Just a pity to see that there is still no GPU support/usage as to accelerate certain functions.
-When using the file selector options/windows I notice some ‘strange’ (e.g. non standard Windows) behavior. E.g. when I want to select a directory to store the output of the conversion queue, I’ve noticed some delays when you click (or try to click?) on the directory/file open icon. And the file/directory browsing behavior is rather different then the ‘normal’ in Windows Explorer. Also you must click on ‘Open’ while (I think) ‘Select’ should be more appropriate.
-Preferences Setting: most options have ‘hoover over’ info text, but not all of them. Sometimes you put the mouse cursor on an item, but nothing happens… Especially the ones you might expect info, there is no info… :confused:

I hope this helps in getting the final 5.4 release ready!
Any additional questions? Just ask.


#24

I think at one point OpenCL was considered for some functions, as proposed by @heckflosse :


#25

I have been using dev builds for a while now because I could not wait so long for the new features which are simply great. You are doing such a great job and the program is getting better and better. I switched from Lightroom to RawTherapee when Lightroom 7 was announced and I have not started Lightroom even once since then.

However, there is an annoyance with this release candidate. I run the dev builds with the English GUI and switched to system language now, which is German (Austria). Unfortunately, that does not work anymore. I have tried to start RawTherapee with renamed configuration directories to look if there is something up with them with no effect.

I am running RawTherapee on Windows 10. To me this is just a minor annoyance, I have just switched to German manually which works perfectly fine and I am not sure what language I prefer anyway. Using the system language still worked with dev builds about two months ago when I started using dev builds, if I remember correctly.


(Ingo Weyrich) #26

Confirmed. Fixed for de, fr, nl, es, it, pt

Thanks for reporting :+1:


#27

Ok… but why was it never implemented?
Because it already dates back to 2015.

Just to give you an idea of how much a simple GPU can accelerate graphics processing:
When I run PTGui Pro to stitch a large panorama image, it only takes a few seconds to generate a huge output file. As long as OpenCL GPU acceleration is switched on.
But when I rely only on my CPU, the same process takes about 10-15x times longer! (i7980x CPU versus R9 270x GPU)


(Morgan Hardwood) #28

If you want to fly to the moon, sticking fins and a rocket engine on to a rusty old bus does not a good foundation make. The first step was to optimize the code and to make the most of SSE2. The next step is to unify the pipelines. Maybe OpenCL will come next.


(Ingo Weyrich) #29

It dates back to 2013 Reported by heckflosse@i-weyrich.de on 2013-01-24 23:20:08
At that time fast GPUs were expensive and the simpler approach was to use SSE2 code and make better use of multiple cores to speed up rt.
Additionally there are algorithms where currently no GPU solution exists. Look at the raw decoders. Most of them are still single threaded. Some of them are multi-threaded, but afaik none of them is vectorized.


#30

I am impressed, I am really impressed. That was super quick. Thanks a lot!


(Andrew) #31

Just to mention, I built this tonight but it didn’t compile first time round. I saw the bit about possibly running faster with LTO ON but lots of errors resulted, e.g.

[100%] Linking CXX executable rawtherapee
/tmp/ccYOkOYJ.ltrans0.ltrans.o: In function BayerProcess::methodChanged()': <artificial>:(.text+0x326b): undefined reference tortengine::procparams::RAWParams::BayerSensor::getMethodString(rtengine::procparams::RAWParams::BayerSensor::Method)’
/tmp/ccYOkOYJ.ltrans0.ltrans.o: In function BatchToolPanelCoordinator::getAutoWB(double&, double&, double, double)': <artificial>:(.text+0x3612): undefined reference tortengine::ColorTemp::ColorTemp(double, double, double, double)’
/tmp/ccYOkOYJ.ltrans0.ltrans.o: In function `BayerProcess::write(rtengine::procparams::ProcParams*, ParamsEdited*)’:
:(.text+0x4e5b): undefined reference to

and lots more.
So I repeated with LTO OFF, this time no errors and it loaded. (haven’t processed anything yet…)

Thanks to all for this new version.


(Ingo Weyrich) #32

@RawConvert Was that on Windows/msys2? There LTO does not work unfortunately :frowning:


(Andrew) #33

Actually there is one possible glitch with LTO OFF in the CMAKE bit -

– Performing Test _fftw3f_multithread
– Performing Test _fftw3f_multithread - Failed
– Performing Test LENSFUN_HAS_LOAD_DIRECTORY
– Performing Test LENSFUN_HAS_LOAD_DIRECTORY - Failed

I haven’t installed Lensfun so that’s ok I presume, but what about the fftw3f? Does this matter?


(Andrew) #34

hi, no, Ubuntu 16.04


(Carmelo Dr Raw) #35

Issue is here:


(Ingo Weyrich) #36

That’s just a test whether your fftw3 library is able to multithread or not. If it’s able to multithread, processing of hdr tonemapping in rt will be faster (if your machine has more than one core). That’s all.


(Andrew) #37

Ok thanks, I won’t worry about that then.


#38

Ok. I was just wondering why not.
Because the performance gain is huge imho.

And what about the other remarks I made about rc2? Any additional clarification needed?


(Jean-Christophe) #39

I took the liberty to commit your patch to dev as it worked fine here too.


(Markel) #40

Would lag/freeze on my pc until I disabled fullscreen optimizations (compatibility settings). Wacom pen was also glitchy, still is but less so after doing the aforementioned. Text has a color space mismatch appearance, but management is set to display. Would be nice if all of the adjustments were minimized upon opening, it’s a bit intimidating/misclick-anxiety-inducing with them all open on startup. Could be a setting I’m overlooking. W10 x64 i3 @ 2.2GHz Intel HD3000 16GB ram.