Filmulator v0.11.0 released!

Now announcing Filmulator version 0.11.0!


  • Filmulator now properly handles cameras where whitepoint varies according to the set ISO. To benefit from this, go to the Settings tab and tell Filmulator to download the latest camera constants.
  • The auto CA correction now loads properly for manual lenses on selecting an image.
  • Reduce Memory Usage now works correctly when quick preview is on.


  • The file selection for import no longer needs the text box cleared in between uses.
  • Files that match the name filters but cannot be processed (weird DNGs especially) are now properly ignored when importing.


  • The Organize view now defaults to the current day upon opening.
  • When on the Organize tab, pressing left/right switches the currently selected day, and holding shift will let you select multiple days.


  • Double-clicking on an image in the queue now brings you directly to the Filmulate tab if you weren’t already there.
  • When an image is right-clicked, the rating shortcuts apply to that image instead of the image currently open for editing.


  • ARM AArch64 builds are now possible, but no premade builds are available at this time.
  • The version number can now be seen at the bottom right corner of the Settings tab.

Builds are available for Linux and Windows, but still no MacOS builds are available at this time. Please get in touch if you can help set up CI for MacOS builds.


Hi CarVac!
Thanks for the new version of filmulator.
I’m on Manjaro and this new version crashes when saving a JPEG or TIFF.
The 0.10 version works perfectly here.

Is it possible to change the output directory? I didn’t find it anywhere, maybe I’m dumb or it’s wanted.

Thanks anyway!

Hm, that’s odd. Running the released appimage, it definitely saves properly for me, and I didn’t change anything regarding saving since 0.10.2, though 0.10.2 had some changes regarding metadata.

There’s currently no way to change where the files are saved; they’re always saved next to the raw.

Do any of the 0.11.0 release candidates on the nightly builds thread have this issue?

Ill give the windows one a try

Not crashing on Windows but it doesn’t appear to save either TiFF or JPG …at least for me

#2 on HackerNews. Congrats !

If you go to the folder containing the raw files, are they not there?

No the button goes briefly orange when pressed then no evidence of activity and no files…Downloaded a file so file was loaded from downloads…no sign of a jpg or tiff export

Found them. I did not notice but when I opened the file from downloads it created a folder on my desktop 2020/11 with a copy of the raw and the exported files…So export is working as expected I just didn’t notice the import created new folders and moved my file…

1 Like

You can use the preset buttons on the import tab to choose not to copy the files, or you can alternatively move the files manually and teach Filmulator the new location.

Sorry to scare you. I should have paid more attension

I tried 0.11.0 appimage on Mint and it works there.
Apparently the problem appears on Manjaro (kernel 5.4.89) when converting files from a NFS partition. On Mint (kernel 5.4.0) it works.
Tell me if you need any more testing.


OK, nailed it: the last rc to work is the 4th, rc5 shows the problem.
diff time :slight_smile:

1 Like

I can’t fathom what could have changed to cause an issue, and if a dependency updated that means it updated within the same day…

I’ll try to trigger a rebuild of rc4 so you can see if it fails (in which case it’s a dependency).

Hi CarVAc, I would love to test on my Mac but there is no build.
Please could you provide a prebuilt Mac version so that I can test.


I’d like to but I do not have a way to build for mac right now. It seems GitHub Actions can build for mac but I need someone to help set up CI for it.

Thanks for your very prompt reply.
I look forward to seeing a build so I can test.

Hi Carvac,
I read the dpreview post and found Filmulator very promising. Unfortunately Filmulator is not working properly on my System (Windows 10 pro) . All thumbnails/images in the Organize and Filmulate pane are completely black. The metadata of the Camera (EOS R 6) as they are displayed in the top row of the filmulate pane appear to be correct .
Any idea what the issue could be?

Is this lossy compressed (C-RAW) or lossless compressed raw?

I’m not sure offhand whether LibRaw works with C-RAW or not; I’ll test after work.

It might also be specifically the R5 and R6; they’re not in the LibRaw supported camera list yet.