Flat Field correction in ART is leave either a ghost in the center or a redish hue when testing FF DNGs

Hi ART forum

I seem to have a a Flat Field issue in ART which was resolved the last time I ventured into DNG editing. The issue was actually with RT (as I didn’t really know ART then) as you can see here Huawei DNG files and flat field correction in rawtheapee produces a purple vignette [solved] - #11 by Mint. In short agriggio Alfredo quickly solved it and the solution was picked up by heckflosse Ingo Weyrich at RT. So back then both ART and RT could do Flat Field correction without any strange magenta/purple hues. Now I am trying to give RAW editing another go and I settled for ART because I find the GUI less intimidating then RT (and I really like you can turn the modules on and off so easily) and Darktable seem to freeze and crash a lot. However when I try to use my Flat Field correction files (DNG) in latest ART 1.14 from Apprepo - AppImage: ART now strange things occur. If I test my Flat Field DNG on it self, the result should be a completely flat white image. If I test it with RT latest 5.8 Dev (Release Automated Builds · Beep6581/RawTherapee · GitHub) that is exactly what happens. If I do the same in ART the test gives a white image but with a dark uneven ghost like area in the middle. This happens even if the module is not turned on (which is double peculiar because without asking ART for anything it does something). In RT if you don’t ask for FF correction you can see the dark greenish corners as you’d suspect. Now if I manually select the flat field DNG in ART then it sort of removes the corners but leaves and red/orange hue. So if it was sorted before in ART and the solution was implemented in RT and RT is working flawless but ART is not why is that?
Any suggestions? I suppose I could simply get over my RT fright and be done with it.
Screen shots for anybody who is interested.


Flat Field DNG
IMG_20200620_170726MAIN.dng (76.2 MB)

indeed, there seems to be a regression of some sort. Thanks for reporting, I will look into it.

That was a faster than fast reply.


it should be fixed now.


this might be a good idea regardless.


Hi Thank you very much. It is incredible how fast you can do these things.
A question - how can I get hold of the fix? You are right I can just use RT however I like the simpler interface ART has.
Can you perhaps link me to the build?
Thank you again

There’s no build yet, sorry. You need to compile it yourself or wait for the next release…

1 Like

Hi. Thank you - OK - perhaps I might try and build it myself (a new thing for me but how hard can it be). So far I have managed to clone the source from your bitbucket with git clone agriggio / ART / wiki / Home — Bitbucket

Hi. Deep breath and I did it - almost. Build it I mean. OK I managed to get, build and install LibRaw and mimalloc plus build the 1.14 (using Ocroquette as base How to build ART on Ubuntu 22.04 | ocroquette's technical Blog). Its a build run test before I try to add the fix agriggio / ART / commit / 8f12deb19d76 — Bitbucket but when I run ART I get this mimalloc error - libmimalloc.so.2: cannot open shared object file: No such file or directory. I saw in How to compile ART? - #12 by agriggio that mimalloc 2.0 is now included and should work. Is there a commit/fix I need to find and add before I build?

Hi, the error means that the mimalloc library is not found at runtime. Try running sudo ldconfig from a terminal and rerun ART afterwards; there’s a chance that this is all you need to fix it. If not, I will need more details about what you did…


Yes it runs! So I sort of presume that my builds were all ok. Now I just have to get and copy paste your fix in the new bitbucket rtengine/ffmanager.cc and overwrite the old /rtengine/ffmanager.cc and build again.
I will try that.
Thank you

Yes I managed it. It runs and your fix for the Flat Field seems to work too. The Flat Field image on to itself is white without any colour cast. Done