Gmic Qt for Gimp 2.10.34 - o.s. macOS 14 Sonoma

Hi, I tried to install Gmic Qt for Gimp 2.10.34 with o.s. macOS 14 Sonoma, but it doesn’t work. Somewhere online I found the file GMIC-Gimp-2.10-osx.tgz, I unpacked it and pasted the file and folder thus obtained into the Gimp plugins folder.
But it did not work.
Is it the file that is wrong? Or the folder where it was pasted?
Screenshot 2023-10-13 alle 08.30.55


I hope you didn’t download this file from a suspicious website… What is inside the GMIC folder?

Try creating a folder named gimp_gmic_qt and move the gimp_gmic_qt file in it, then launch Gimp.
Is it working?

Unfortunately, the official website does not have the macOS version of gmic.
I did the test you indicated but the operating system doesn’t allow me to call a folder with the same name as an existing file and if I replace the file with it the plugin doesn’t work.
However, the unzipped folder contains these folders, each with its own files.
Thank you for your kind reply.

You can temporarily rename the gmic_gimp_qt file, create the folder, then put the file inside before renaming it to the original name.

Not sure where that GMIC folder should go though.

Yes, in the end I had already done as you say.
For the folder location some tutorials say to do what I did.
It’s probably the downloaded file that isn’t the right version.

I hope that some user can attach the right file here by copying it from their Gimp in macOS version.
Thanks for the help.

I also tried installing with Macports, but the procedure lasts for many hours without ever finishing …
Has anyone tried it?