Inpaint settings

Hi, there is this photo where I want to remove the tree:
http://betazoid.bplaced.net/lilac/wp-content/uploads/2018/05/P4201881.jpg

I am trying to remove the tree with the help of the inpaint-filters. I have once achieved a very good result, but I do not remember how any more. I could not reproduce the result. I think the multi-scale version works best, but what are the optimal settings? I have tried many different settings, but I am not satisfied. Usually the inserted area is too light, or the red borders of the mask are visible.
Also, many times the preview looks really great, but the end-result does not.
What is the solution?

Thanks in acvance for the help
b

2018-05-19-121820_547x432_scrot

Even with default settings (using patch based because I was not paying attention) there is a reasonable result.

The only thing to remember is use the pencil tool to paint in the mask.

The paint-tool creates anti-aliased pixels which gives rise to edge artefacts.

quick example, default Inpaint (patch-based): https://i.imgur.com/g5UOQAb.jpg

OK, thanks. The type of the drawing tool is the important thing. Anyway the brush tool is very bad for this kind of repair.
Meanwhile I also achieved several good and reproducible results. One with the morphological inpaint and I think I dilated the mask a little, but that took very long (at least 15 minutes). The multi-scale tool is much quicker. In Krita I used the ink-tool nr. 1, and I dilated the mask a litte.

Another question: which brush/drawing tool do I need to use in Krita so there is no red mask border?
Inpaint works well in Gimp if I use the pencil, but I have tried so many brushes/pancils/pens in Krita and there is always the border. Eventually I painted the mask in Gimp and opened the file (with the painted mask) in Krita and ran G’mix inpaint and it looked nice!
What’s the trick in Krita?

Any tool which doesn’t do anti-aliasing or which lets you turn it off.

1 Like

Thanks. However, I only achieved with one drawing tool a good result in Krita. There must be an additional setting. With the other pens/pencils/brushes, there were still some red blotches.

@betazoid the filter looks for pure red (R=100%, G=0%, B=0%). If you paint with a tool which uses anti-aliasing, feathering, or anything similar, it will blend colors on the periphery to make the transition look nice, but blending makes the pixels on the transition area not R=100%, G=0%, B=0%.

This comes up now and then. I wonder whether the G’MIC plugin could SelectSharpen the selection before it applies the filter. @David_Tschumperle

hard brush in krita

I do not fins these settings in Krita 4

That badly, it is important have a brush without soft.
It is necessary to consult in the forum of krita