Live Stacking on NINA with Siril, possible ?

Speed depends on many things: the size of images obviously, but also the quality of the demosaicing algorithm chosen, if cosmetic correction is enabled with dark calibration, if dark and flat calibration is used, the type of registration, and to a lesser extent the type of stacking.

You’re talking about PI and siril here, but just to be clear: the best alternative is probably ALS, which is much better looking and dedicated to this task.

1 Like

oh i didn’t knew this one…
i will check too


I’m trying to test Siril with the LiveStacking option but I can’t get it to work.

When starting the livestacking session, Siril expects the image files in a certain directory and the following message appears:

“Live Stacking waiting for files”
My question is this:

In which directory should the images be dumped and in what format?
The version I’m testing is this:

Siril 1.1.0
commit 7db5e90
Unstable DevelopmentVersion

Thanks and regards


Hi, it’s the same directory as usual, the current working directory, and images are expected in FITS format currently. Maybe the FITS extension needs to be set to the extension of your files in the preferences.

Hello, Vincent.

thanks for the reply.

I have modified the siril.config file with the path of the working directory and the *.fits extension as the image file.

extension = “.fits”;
FITS_type = 1;

I still have the problem since I can’t get the stack to start and the warning always comes out
“Live Stacking waiting for files”

Does Siril need to previously convert the files to its format or does it do it directly?

The truth is that I have tried with files from different cameras that Siril processes and edits without problems, but in the LiveStacking process it either doesn’t recognize them or I’m not doing it right.

Any ideas?

thanks and regards


You shouldn’t edit the config file, it’s all available from the GUI or commands. I haven’t tried the livestacking in a while, maybe it doesn’t actually work. This is the development version, don’t expect this kind of unannounced feature to work by the way.
It’s supposed to process incoming FITS files from the current working directory, at some point it did that at least.

Last time I tried it was working well however.


What development version did you try it on?

The master branch.
This is the next 1.2.0 release.