new version 1.5.4

I compiled version 1.5.4 stable and my user commands are not active in the context menu. However, I copied the folder correctly. Where do we put the usercommands folder in the stable version?
@agriggio

for the development version I put them there

my two versions art (master dev) and ARTstable (release) were compiled from the same / programs folder

There should be no difference, user commands go in $HOME/.config/ART/usercommands

:thinking: strange…

Are you sure you didn’t specify some non-default option to cmake?

its good! I just realized that there were several ART files in .config it’s solved … Thank you for your patience

@agriggio
@Carmelo_DrRaw has problems building with the automatic CI build as he is no longer able to find the old version of libjpegturbo permitting to compile jdatsrc.cc
see Nightly Development Builds for Windows Users

@heckflosse is going to commit a patch to get around the issue see https://github.com/Beep6581/RawTherapee/issues/4713

Could you have a look at that as the problem is the same with ART
Thanks

Sure,thanks for the heads up!

@gaaned92 how do I upgrade libjpegturbo on windows? Thanks!

in the meantime, I’ve just pushed a change to clean up the jpeg handling code. Can someone with libjpegturbo 2.x test and see if it works? Thanks!

If you followed the instructions from here: http://rawpedia.rawtherapee.com/Windows , all you have to do is to remove
IgnorePkg = mingw-w64-x86_64-libjpeg-turbo
from \etc\pacman.conf. After this, when you update msys libjpeg-turbo will get updated.

I just tried it now with an up to date msys2 and libjpeg-turbo 2.0.5-1 and all is fine. It compiles and seems to work just fine.

confirmed.
I renamed raw files with the jpg suffix. ART ignores them it seems without message even under debug.
I cannot believe you can make such amount of corrections in a so small time.

Regarding exiv2: I hope the issue is corrected.

So here is the example :

  • Please open example.png then apply example.arp. The shapes are under Smoothing.
  • Step 1 is the result when I did a shape, saved the profile, close the file and re-opened it.
  • Step 2 is what the shape should look like, minus the workaround I used to make the shape working as intended.

So where is the problem ?

  • Look for a very small line. The left point of this small line is actually the start of the shape.
  • Then I did the shape anti-clockwise.
  • So when I did the shape the first time, both lines before and after the starting point were changed in curve. If you do that, you can be sure that one of the two curves will be transformed in two straight lines.
  • So I saved the profile, close and re-open the file, apply the profile. Then a curve (or more, one time I had 3 curve changed in straight lines…) is changed in 2 straight lines. The straight lines are the one used to create the curve.

The workaround :

  • When I see the problem, I use the meeting point of the 2 straight lines, and put it really near the next point.
  • Then I re-make the curve with the other line.
  • Save the profile, close, re-open to check that it’s OK, because sometimes I put the meeting point in the wrong side, if you see what I mean…

So, in conclusion on my side, most of the time the problem occurs when the 2 lines around the starting point are curves. But, I had times with 2 or more curves for one shape. Next time I have this, I send to you.
I hope that I was clear enough.
Example.7z (4.2 KB)

Thanks, now I can reproduce. Turns out this is likely to be an exiv2 bug, which I’ve just reported:

However, I’ve implemented a workaround that should solve this hopefully.

Thanks. ^^
Edit : OK, I understood, you transform coordinates and stuff in base 64.

By the way, @agriggio and @gaaned92 I’ve noticed that with the last commit some more libraries are now added to the dependencies list (at least on Windows):

  • libcrypto-1_1-x64.dll
  • libcurl-4.dll
  • libidn2-0.dll
  • libnghttp2-14.dll
  • libpsl-5.dll
  • libssh2-1.dll
  • libssl-1_1-x64.dll
  • libunistring-2.dll

At least on my computer, ART did not wanted to start without all of the above.

I suspect these come from exiv2. Can you trying building the library yourself and see if you can n turn off “stuff related to http”? :slight_smile:
Here nothing changed, and I don’t remember shipping those libs in the installer

I have the feeling that I added thoses dependencies for some time.
After testing with last vesion of exiv2 0.27-maintenance branch, I find that they are no longer used.

to build exiv2

cmake -G “MSYS Makefiles” -DEXIV2_ENABLE_WIN_UNICODE=On -DCMAKE_CXX_STANDARD=11 -DCMAKE_CXX_FLAGS=-Wno-deprecated -DCMAKE_INSTALL_PREFIX=<installdir> -DCMAKE_INSTALL_DATAROOTDIR=<installdir>/share …/exiv2 -DCMAKE_BUILD_TYPE=Release

to link with it
PKG_CONFIG_PATH=<installdir>"/lib/pkgconfig:"$PKG_CONFIG_PATH
Please confirm

Hi Alberto @agriggio,

I’ve recorded a screen cast with WB bug demonstration. If temp is close to 1900 or less, and you zoom to 100% - image turns into very greenish and stays like that on any zoom level. Moving back in history fixes it (until you zoom to 100% again), but resetting WB setting doesn’t. It’s reproducing on any of my images (from different cameras), and on any processing profile (neutral, or custom).

2020-10-23_19-06-33.mkv (23.1 MB)

Just checked Rawtherapee 5.8, and there is no such bug there. Would you be able to take a look?
Thanks.

Thanks, I’ll see what is going on