OpenCL on Fedora

you should not install the Fedora package but the package from

see install | darktable

fedora is under unknown.

1 Like

Thanks, it also worked. :+1:

The OpenCL problem persists and I still don’t know what the solution is, or if there is a solution.

Since your log says
0.096445 [opencl_init] discarding device 0 'gfx902:xnack+' due to insufficient global memory (512MB).

I think it’s quite clear that Darkktable refuses your APU because it can not access more than 512Mb of memory; whatever the driver you have.


Sorry for the incredible late response.

I managed to enable OpenCL, but darktable’s performance was bad. Now, I’m using darktable without OpenCL.

How did you manage to do that? I’ve bought a second SSD to have Windows on one of them and Linux on the other. My choice was Fedora 35 and I tried regular install from GNOME Software Manager (RPM package) and from build.opensuse - in both cases opencl in preferences is grayed out.

I’ve also installed packages for opencl & headers, still no luck.

My GPU is Gigabyte GTX 1050 Ti G1, Nvidia’s proprietary 510 drivers.
The same version of drivers and darkatble (3.8.1) under Windows work like a charm.