PhotoFlow as a GIMP plug-in - now usable!


(Carmelo Dr Raw) #21

Hi @Patrick_Depoix ! Thanks for the heads up, I have added OpenEXR to the list of required development packages.

Concerning VIPS, it is already listed separately:


(Patrick Depoix) #22

I have follow your explanations with ./build_all.sh at the place.
but i havn’t obtained the plugin folder in my Release folder?


(Carmelo Dr Raw) #23

What is the output of

ls Release

Thanks!


(Patrick Depoix) #24

patrinux@patrinux-ordi ~/PhotoFlow/build $ ls Release
bin
CMakeCache.txt
CMakeFiles
cmake_install.cmake
CPackConfig.cmake
CPackSourceConfig.cmake
data
install_manifest.txt
Makefile
po
share
src

I can add that in /home/patrinux/PhotoFlow/build/Release/share/photoflow
there are not the plugin folder with pfgimp?


(Carmelo Dr Raw) #25

Strange… could you send me a private message with the full output of the

make install

command?


(Patrick Depoix) #26

So you must add this libgegl-0.2-0 and libgimp2.0-dev
to your long list of required build dependencies too!


#27

Photoflow compiles without complaint as in post #1.
but gives no Release/share/photoflow/plug-in directory…
Trying to launch the executable photoflow gives:

/PhotoFlow/build/Release/bin/photoflow
terminate called after throwing an instance of 'Glib::ConvertError’
exePath: Abandon (core dumped)

Grrr ?


(Carmelo Dr Raw) #28

Hi!

Concerning the plug-in, I am in the process of completely changing the way the plug-in is implemented and invoked. I’ll post a message when this will be finished and tested, meanwhile you can get an idea of what is going on from here.
Shortly speacking, the normal photoflow executable is now also acting as the plug-in, and there is a small wrapper code that should be compiled as the actual GIMP plug-in and that takes care of invoking the photoflow command with the appropriate parameters.

Concerning, the Glib error, I have no idea what could be the reason… could you re-configure and re-compile photoflow with -DCMAKE_BUILD_TYPE=Test and then run the executable with gdb, so that we can see where exactly the code is failing?

Thanks!


#29

Hi, signore Ferrero!
Building pf-gimp works with (see attachment) !!

(some problems to open a raw file solved uninstalling darktable, I dont like photosh… interfaces)
I use PF only for what Gimp does not make: I use gmic, lensfun, persp correction… only with Gimp.

Tried to build PF as DrRaw said:

(gdb) run

Not an expert with gdb… but if I can try something to help

Best regards

Le vendredi 17 février 2017 11:07:50 CET, vous avez écrit :


(Carmelo Dr Raw) #30

Salve, signor Alex ;-)!!!

attachments seem not to be stored when you answer messages here, unfortunately…

Concerning how to use gdb, here is the basics:

  • start gdb with the full path to the photoflow executable as parameter

  • when photoflow crashes, write the following at the gdb prompt:

    thread apply all bt

  • send me the full output of the gdb backtrace

Do not hesitate to ask further questions if something is not clear!


#31

¡Hola señor!

Attachment was https://github.com/aferrero2707/PhFGimp from yesterday.

gdb Photoflow (if no mistake), hope it helps:

(gdb) run 
Starting program: /home/ego/Système/PhotoFlow/build/Release/bin/photoflow  
[Thread debugging using libthread_db enabled] 
Using host libthread_db library "/usr/lib/libthread_db.so.1". 
terminate called after throwing an instance of 'Glib::ConvertError' 
exePath:  
Program received signal SIGABRT, Aborted. 
0x00007fffef28e04f in raise () from /usr/lib/libc.so.6 
(gdb) thread apply all bt 

Thread 1 (Thread 0x7ffff7f85980 (LWP 15303)): 
#0  0x00007fffef28e04f in raise () at /usr/lib/libc.so.6 
#1  0x00007fffef28f47a in abort () at /usr/lib/libc.so.6 
#2  0x00007fffefba54ed in __gnu_cxx::__verbose_terminate_handler() () 
   at /build/gcc/src/gcc/libstdc++-v3/libsupc++/vterminate.cc:95 
#3  0x00007fffefba32a6 in __cxxabiv1::__terminate(void (*)()) (handler=<optimized out>) 
   at /build/gcc/src/gcc/libstdc++-v3/libsupc++/eh_terminate.cc:47 
#4  0x00007fffefba32f1 in std::terminate() () at /build/gcc/src/gcc/libstdc++-v3/libsupc++/eh_terminate.cc:57 
#5  0x00007fffefba3508 in __cxxabiv1::__cxa_throw(void*, std::type_info*, void (*)(void*)) (obj=0x1df6870, tinfo=0x7ffff2623c
d0 <typeinfo for Glib::ConvertError>, dest=0x7ffff23e84e0 <Glib::ConvertError::~ConvertError()>) 
   at /build/gcc/src/gcc/libstdc++-v3/libsupc++/eh_throw.cc:87                                                               
#6  0x00007ffff23e8367 in Glib::ConvertError::throw_func(_GError*) () at /usr/lib/libglibmm-2.4.so.1                          
#7  0x00007ffff23fdc6e in Glib::Error::throw_exception(_GError*) () at /usr/lib/libglibmm-2.4.so.1                            
#8  0x00007ffff24099b2 in Glib::operator<<(std::ostream&, Glib::ustring const&) () at /usr/lib/libglibmm-2.4.so.1 
#9  0x00000000008739f1 in PF::PhotoFlow::PhotoFlow() (this=0x1df5a60) 
   at /home/ego/Système/PhotoFlow/src/base/photoflow.cc:219 
#10 0x0000000000875025 in PF::PhotoFlow::Instance() () at /home/ego/Système/PhotoFlow/src/base/photoflow.cc:291 
#11 0x000000000058269c in main(int, char**) (argc=<optimized out>, argv=<optimized out>) 
   at /home/ego/Système/PhotoFlow/src/main.cc:198 
(gdb) 

Le vendredi 17 février 2017 23:04:19 CET, vous avez écrit :


(Carmelo Dr Raw) #32

It might be that photoflow is not handling correctly the UTF8 characters in your path (you have a folder called Système).

Would you have the possibility to compile photoflow in a path with only standard characters?

From my side I will see if I can reproduce the problem…

Thanks!


#33

Ok… it works in a “standard” characters directory.
UTF8 only is god, while some people use yet medieval measurement systems with inches, pounds, miles, onces, 1/8", “legal” paper, …
a language with “var ‘изменчивый’ = 1” doesnt exist (yet)

But thanks for your work!!!


(Carmelo Dr Raw) #34

I agree, it MUST work with UTF8 paths… hopefully I will be able to reproduce the crash on my system and then fix all the places where UTF8 characters are not handled correctly…

I must admit that I still have medieval habits concerning my own folders structure :wink:


#35

Was not a reproach for you personnally! (see my edited post above)


(Carmelo Dr Raw) #36

I was just joking, don’t worry!!! It takes much more than that to make me upset, I assure you :smiley:

Anyhow, I just did a quick test under OSX and I could not reproduce your problem. Which OS and Glib version are you using?


#37

Linux Manjaro stable uptodate (64 bit 16.10.2) glibc 2.24-2
(not worry!!)


(Gabriele ) #38

Hi all,
after photoflow compiling success I tried to install gimp plugins.
I have GIMP-CCE and when I launch photoflow plugins I have:

Could not execute plug-in “phf_gimp”
(/usr/local/lib/gimp/2.0/plug-ins/phf_gimp)
because it uses an obsolete version of the plug-in protocol.

Any hints??

I have the same erro when I launch GMIC plugin ,too.