Problem Upgrading darktable

Following your suggestion, I right clicked darktable in the apps folder and selected ‘Open’ Again I got the two dialogue boxes. Whichever options I choose, nothing happens.

goto system preferences → Security & Privacy click Privacy tab click Full Disk Access.

Now unlock the lock at bottom by clicking on it and provide your login password now on the right side pan click + and add darktable from applications folder.

hope it will solve your problem

Thanks very much Raj. I followed your instructions and darktable wasn’t in the white list so I did as you suggested and added it. Unfortunately I am still getting:

(It is an active dialogue box it is just greyed out because ScreenFloat was the active window)

As soon as I click on ‘Yes’, I get the following:

(again an active box)

When I click on ‘upgrade database’ the dialogue box vanishes and nothing happens.

This looks like your database could be damaged. Did you try with a fresh install (without your database files data.db and library.db or with a completely empty config folder) ? Did you try to start darktable from the commandline with option -d all to get debug information ?

I’m afraid I am not very knowledgeable with computers. I had darktable on my Mac but it was an old version (2. something) so I went to the darktable site and downloaded 3.8. Everything went as you’d expect and it asked me if I wanted to uninstall the old version. I said yes. I thought it was all ready to go so I attempted to launch darktable first from the launchpad and then from the application folder. Each time (and eachtime thereafter), no matter what I do, I get the same result!

You need to run it from commandline with option -d all to get info what’s failing. Without such information itsjust fishing in troubled water

Open a terminal application. An explanation can be found for example at How to Open and Use Terminal on a Mac, With a Few Basic Commands. To run darktable type

darktable -d all

Then press ENTER or RETURN. You should get a long list of messages in your terminal. These messages are necessary to start debugging your issue.

Thank you all for sticking with me on this. I had to leave the computer for a few hours.

I ran the darktable -d all line and this is the result:

The default interactive shell is now zsh.
To update your account to use zsh, please run chsh -s /bin/zsh.
For more details, please visit Use zsh as the default shell on your Mac - Apple Support.
MacBook-Pro:~ Patrick$ darktabe -d all
-bash: darktabe: command not found
MacBook-Pro:~ Patrick$

Incidentally, although I haven’t the faintest idea what the interactive shell means, I used the link provided but it is no longer an active link.

Well, you forgot an ‘l’ in there, the command should be
“darktable -d all”

Good pick up rvietor, unfortunately that hasn’t fixed the problem

MacBook-Pro:~ Patrick$ darktabe -d all
-bash: darktabe: command not found
MacBook-Pro:~ Patrick$ darktable -d all
-bash: darktable: command not found
MacBook-Pro:~ Patrick$

It’s probable that such a jump of database versions (2.x to 3.8) will not work automatically, there have been many changes in-between. If you don’t have many images in the database and have the edits saved in xmp sidecar files, I would just start from a clean installation and re-import the images (backup first!).

use this command in terminal and tell us what errors you get

/Applications/ -d all


Thanks Raj,

MacBook-Pro:~ Patrick$ /Applications/ -d all
0.004386 application_directory: /Applications/
0.004651 darktable.datadir: /Applications/
0.004774 darktable.plugindir: /Applications/
0.004904 darktable.localedir: /Applications/
0.005116 darktable.configdir: /Users/Patrick/.config/darktable
0.005183 darktable.cachedir: /Users/Patrick/.cache/darktable
0.005288 darktable.sharedir: /Applications/
0.005390 darktable.tmpdir: /private/var/folders/w2/dbx1d9b55y37y62dmc9cclrw0000gn/T
[memory] at startup
[memory] max address space (vmpeak): unknown
[memory] cur address space (vmsize): 4464536 kB
[memory] max used memory (vmhwm ): unknown
[memory] cur used memory (vmrss ): 12636 kB
0.005468 new_xdg_data_dirs: (null)

(process:27816): GLib-GObject-CRITICAL **: 10:47:34.997: g_object_set: assertion ‘G_IS_OBJECT (object)’ failed

Thanks for your advice Guillermo, as I went to bed last night (Australia time) I had pretty much concluded I should clean everything darktable I can find off my hard drive and start again.

Raj very kindly offered to interpret my Terminal data, so I might wait and see what he tells me.

Thanks again.

Is this really the complete output you get starting darktable ? I don’t think so. If there is more output, please post it here.
Regardless of this question : following Guillermo’s advice you can try to start darktable without your old configuration and databases. To do so

  • backup the directory /Users/Patrick/.config/darktable (rename is for example to /Users/Patrick/.config/darktable.bak). Note that .config is a hidden directory. To see it, you have to enable your file browser to show hidden files.
  • launch darktable. Now darktable should start with it’s default settings and with an empty database.

If this is successful the next step will be reimporting your old edits.

Thank you Pehar. That will be a challenge for me for tomorrow.

If things don’t work out it’s not the end of the world. I’m pretty sure I’ve stored most, if not all of my edited photos on an external hard drive and, in any case, there are not that many of them.

Thank you again for your help.

Don’t forget that .config directory is hidden and won’t be visible in the Finder.

However you can set the Finder to display hidden file & directories (ie start with a dot). In an opened Finder window : tap shortcut key : Shift Command “.” (dot key). Finder will then show hidden files and directories semi transparent.

Now you can able to easily access and backup what you need.

Latest update in this sorry saga! We had a power outage all day today so that put a stop to any online work.

I followed Olivier’s instructions but found no config.folder. In the end I decided that. since I have a Timezone back up , and, as stated above, I’m not all that concerned about anything I might lose, I uninstalled darktable and downloaded it again. Exactly the same thing happened. Software, downloaded, files were verified, when I tried to open it I got the same two dialogue boxes I had before and, again, clicking options achieves exactly nothing!

Oh, and by the way, Pehar, that really was the extent of the output in Terminal. Just for completeness, since I have re-downloaded, I put the same command in Terminal. Here is the print out:
Patrick$ /Applications/ -d all
0.001277 application_directory: /Applications/
0.001398 darktable.datadir: /Applications/
0.001541 darktable.plugindir: /Applications/
0.001631 darktable.localedir: /Applications/
0.001734 darktable.configdir: /Users/Patrick/.config/darktable
0.001791 darktable.cachedir: /Users/Patrick/.cache/darktable
0.001863 darktable.sharedir: /Applications/
0.001955 darktable.tmpdir: /private/var/folders/w2/dbx1d9b55y37y62dmc9cclrw0000gn/T
[memory] at startup
[memory] max address space (vmpeak): unknown
[memory] cur address space (vmsize): 4463512 kB
[memory] max used memory (vmhwm ): unknown
[memory] cur used memory (vmrss ): 12580 kB
0.002004 new_xdg_data_dirs: (null)

(process:48159): GLib-GObject-CRITICAL **: 22:48:52.473: g_object_set: assertion ‘G_IS_OBJECT (object)’ failed

Seems pretty much exactly the same as last time. Does the final line hold a clue?

Anyway, I’m off to bed.

thats your config folder.
to rename it just type mv /Users/Patrick/.config/darktable /Users/Patrick/.config/darktable.backup in the terminal and the run /Applications/ -d all again.

(process:48159): GLib-GObject-CRITICAL **: 22:48:52.473: g_object_set: assertion ‘G_IS_OBJECT (object)’ failed doesnt matter, osx and gtk aren’t best friends.

Your issue is suspected to be related to your personal configuration and/or database file(s) in /Users/Patrick/.config/darktable. In this case is does not help to reinstall the application. The installation process does not touch your configuration and database files. To start darktable as a completely fresh install follow the advice of MStraeten. The terminal command

mv /Users/Patrick/.config/darktable /Users/Patrick/.config/darktable.backup

followed by “ENTER” or “RETURN” renames your old config folder. Renaming it from the terminal exempt you from making the hidden directory visible in the finder. If darktable then starts correctly, it will create a new config directory with default settings and an empty database.

That this is the last output is surprising. 2 Milliseconds after dt started and long before the two dialogue boxes you mentioned are appearing. I would have expected to see some dozens or hundreds of messages. I’m on linux and I don’t know how the MacOS application is build and packaged. Perhaps without the code necessary to create the debug info? (only a vague presumption).