Problema Darktable 3.8

Realicé una prueba duplicando una imagen para editarla desde el comienzo, así con los módulos básicos comenzó a funcionar bien, es decir exportaba con opencl activado y se exportaba el Jpeg. Seguí activando módulos de a uno y exportar, sin encontrar problemas. Hasta que se me ocurrió volver a la imagen original y exportarla y el problema volvió a suceder, esa imagen tiene activado a diferencia de la otra el módulo nuevo de Darktabke 3.8 desenfoque con una máscara activa.- Podría ser ese el problema?
Luego volví a la imagen en la cual no apliqué el módulo desenfoque para volver a exportar esa imagen en jpeg y el problema ha vuelto.
Pero parece que activar ese modulo, produce un problema con el opencl que hace que se exporte una imagen en jpeg negra.

Sin ver tu log, es dificil. Esta en este sitio en Windows.

C:\Users[username]\AppData\Local\Microsoft\Windows\INetCache\darktable\darktable-log.txt

Trata de desinstalar el app OpenCL compatibility pack en Windows. Windows lo instala automaticamente. A mi me dio problemas OpenCL hasta que lo quite.

1 Like

He encontrado el archivo log! dime como lo puedo subir al post para que lo veas.

========================================
version: darktable 3.8.0
start: 2022:01:17 20:33:31

2.228371 [opencl_init] opencl related configuration options:
2.231124 [opencl_init]
2.232173 [opencl_init] opencl: 1
2.233618 [opencl_init] opencl_scheduling_profile: ‘default’
2.236481 [opencl_init] opencl_library: ‘’
2.238380 [opencl_init] opencl_memory_requirement: 768
2.240754 [opencl_init] opencl_memory_headroom: 400
2.243083 [opencl_init] opencl_device_priority: ‘/!0,///!0,*’
2.249904 [opencl_init] opencl_mandatory_timeout: 200
2.251964 [opencl_init] opencl_size_roundup: 16
2.254223 [opencl_init] opencl_async_pixelpipe: 0
2.254886 [opencl_init] opencl_synch_cache: active module
2.255860 [opencl_init] opencl_number_event_handles: 25
2.256818 [opencl_init] opencl_micro_nap: 1000
2.257496 [opencl_init] opencl_use_pinned_memory: 0
2.258245 [opencl_init] opencl_use_cpu_devices: 0
2.259074 [opencl_init] opencl_avoid_atomics: 0
2.259695 [opencl_init]
2.261035 [opencl_init] found opencl runtime library ‘OpenCL.dll’
2.261871 [opencl_init] opencl library ‘OpenCL.dll’ found on your system and loaded
2.874128 [opencl_init] found 1 platform
2.876383 [opencl_init] found 1 device
2.876924 [opencl_init] device 0 gfx902' supports image sizes of 16384 x 16384 2.877874 [opencl_init] device 0 gfx902’ allows GPU memory allocations of up to 3081MB
[opencl_init] device 0: gfx902
CANONICAL_NAME: gfx902
GLOBAL_MEM_SIZE: 5673MB
MAX_WORK_GROUP_SIZE: 256
MAX_WORK_ITEM_DIMENSIONS: 3
MAX_WORK_ITEM_SIZES: [ 1024 1024 1024 ]
DRIVER_VERSION: 3075.13 (PAL,HSAIL)
DEVICE_VERSION: OpenCL 2.0 AMD-APP (3075.13)

Creo que hay un botón para subir archivos cuando das reply. En este momento estoy en el celular y no en PC, pero lo veo en mi cell.

darktable-log.txt (51.0 KB)

Aquí está el archivo log…

No veo errores en el OpenCL. Te voy a tener que pedir que hagas los mismo pasos que hiciste, pero usa este comando:

darktable -d opencl -d perf

Esto va a crear un log con más detalles.

Haz actualizado los drivers de la tarjeta de video? Las tarjetas de AMD a veces dan problemas pero hay que investigar porque tienes problemas con el 3.8 y no el 3.6.

1 Like

darktable-log.txt (69.2 KB)

Archivo log ejecutando el comando: “darktable -d opencl -d perf”

Los drivers de la tarjeta de video se encuentran actualizados.

Gustovo, esta parte esta extraña.

42,209662 [opencl_profiling] spent 0,0134 seconds in colorspaces_transform_lab_to_rgb_matrix
42,210745 [opencl_profiling] spent 18446743552,0000 seconds in convolve
42,211605 [opencl_profiling] spent 0,0000 seconds in blendop_mask_rgb_jzczhz

pero a la misma vez no da ningun error. Se me hizo dificil leer el log en español. No estoy acostumbrado a los terminos.

Tal vez borrando los folders de cache kernel fuerze a recrearlos. Para hacer eso, vuelve al folder donde esta el log y borra todos los folders que estan alli.

C:\Users[username]\AppData\Local\Microsoft\Windows\INetCache\darktable\

1 Like

Prueba a actualizar los drivers de la tarjeta gráfica.


Try to upgrade the drivers for your graphic cards.

1 Like

He borrado las carpetas de cache kernel y Darktable las ha vuelto a generar.
Volví a ejecutar el comando “darktable -d opencl -d perf”

Ahora el Archivo txt Log está totalmente vacío. No se genera reporte alguno en ese archivo.

Y el problema no se ha solucionado.

Me imagino que sabes que puedes seguir usando 3.6 mientras arreglas el problema de compatibilidad con opencl en la 3.8.

Puedes mantener dos instancias de DT funcionando, pero hay que lanzarlas indicando el directorio donde está la configuración y la base de datos con --configdir y tener dos directorios separados.

Claro que si ya has convertido la base de datos a la 3.8 es muy probable que no la puedas abrir en la 3.6, pero si miras en la carpeta de configuración de DT verás que cuando hizo la conversión te creó otra copia de la base de datos que tenías en ese momento en la 3.6 antes de actualizar (en realidad hay dos ficheros de base de datos).

También puede haber algún problema con los xmp que almacenan los parámetros de edición del raw, busca info por el foro.

La otra opción es desactivar opencl mientras se arregla el problema pero si tu cpu no es muy moderna será muy lento.

1 Like

Realicé los siguientes pasos:

  1. He reinstalado manualmente los drivers de video descargando los mismos directamente desde la la web de AMD (https://www.amd.com/es/support) ya que Windows me indicaba que tenía la ultima versión de los Drivers.

  2. Borré las carpetas de cache kernel para forzar a recrearlos.

  3. Inicié Darktable con el comando: “darktable -d opencl -d perf”

  4. Realicé la exportación a Jpeg de la imagen que me genera el problema y el Jpeg sigue saliendo negro, como en los anteriores intentos.
    Lo único que hizo distinto fue que el software nuevo de AMD me detectó un problema de incompatibilidad que antes no había salido al no tener instalado ese programa. Adjunto el cartel que me salió
    error gráficos detectado por AMD

El mismo software de AMD permite realizar el reporte de error con los detalles para enviárselos a ellos, así que envié el reporte.

Por lo que he visto, puedo decir que el problema que tengo es una incompatibilidad de esta versión 3.8 con mi placa de video integrada.

Cualquier avance positivo se los haré saber.

Muchas gracias

Interesante. El programa te permite ver el reporte?

El número en segundos tan alto me hizo pensar un error en matemáticas, como tratar de dividir entre 0.

¿Pero el problema es con una sola imagen?

Yo te entendía que te pasaba con todas las imágenes, que las veías en negro.

SI es una imagen puede ser un problema con un módulo concreto que use alguna característica especial, o un bug en ése módulo.

Estaría bien que pongar la imagen concreta con el xmp del revelado que lleva al problema, así los desarrolladores podrán ver mejor cuál es el problema.

Para facilitar la labor de los que te leen por aquí, que en su mayoría son de habla inglesa, estaría bien que lo traduzcas con el deepl por ejemplo y lo pongas también traducido (o al principio traducido y después en español, ya que la traducción no será perfecta).

I made a test by duplicating an image to edit it from the beginning, so with the basic modules it started to work well, that is to say it exported with opencl activated and the Jpeg was exported. I kept on activating modules one by one and exporting, without encountering any problems. Until it occurred to me to go back to the original image and export it and the problem happened again, that image has activated unlike the other one the new Darktabke 3.8 blur module with an active mask - could that be the problem?
Then I went back to the image on which I did not apply the blur module to re-export that image in jpeg and the problem is back.
But it seems that activating that module, produces a problem with opencl that causes a black jpeg image to be exported.

Translated with www.DeepL.com/Translator (free version)

Ese module (Blurs), usa convolution. Ese el mismo que calculó 18446743552,0000 seconds in convolve. Puede ser que tenga un error en el modulo en el OpenCL. Debes reportarlo con el xmp para que otros lo puedan recrear.

The Blurs module uses convolution. That is the step in that is giving you the very high duration (incorrect) 18446743552,0000 seconds in convolve. It likely has a bug in the OpenCL. I think you should report it with the xmp.

1 Like

Gracias, me podrías indicar como se reporta el error? Y si solo debo subir el archivo xmp o es necesario el archivo de la imagen?

Thanks, could you tell me how to report the error? And if I only have to upload the xmp file or do I need the image file?

Para que puedan comprobar los devs, será necesario que subas el raw y el xmp.
Así pueden ver si es ése módulo, si se reproducen el problema en todos los ordenadores y es algo específico a cómo se utiliza en esa imagen y es un bug del módulo, o sólo en algunas tarjetas gráficas y es problema del driver de la tarjeta (o de la implementación del módulo en opencl, que parece más probable, si como dices en cpu te funciona).

Sin ella es difícil que puedan ponerse a trabajar o comprobar, porque hay demasiadas opciones y frentes abiertos.


In order for the devs to check, you will need to upload the raw and xmp.
So they can see if it is that module, if they reproduce the problem in all computers and it is something specific to how it is used in that image and it is a bug of the module, or only in some graphics cards and it is a problem of the driver of the card (or of the implementation of the module in opencl, which seems more likely, if as you say in cpu it works for you).

Without it is difficult for them to get to work or check, because there are too many options and open fronts.

1 Like

CRW_9501.DNG (24.0 MB)
CRW_9501.DNG.xmp (15.4 KB)


Subo los archivos donde pude reproducir el error utilizando el módulo desenfoque. Aclaro que mi cámara una Canon Sx530 no dispara originalmente en RAW sino que utilizo un programa que me permite hacerlo (CHDK) y genera estos archivos DNG. Adjunto el archivo xmp con los ajustes realizados.
Además, adjunto dos archivos Jpeg, uno con la exportación realizada con Opencl activo y el segundo con el Opencl desactivado.

I upload the files where I was able to reproduce the error using the blur module. I comment that my camera a Canon Sx530 does not shoot originally in RAW, but I use a program that allows me to do it (CHDK) and generates these DNG files. I attach the xmp file with the adjustments made.
Also, I attach two Jpeg files, one with the export made with Opencl active and the second with Opencl deactivated.