Raw File opening problem

Hi Alberto.

Thank you for your effort for developing ART.

I use ART in Windows10 (21H2). After Ver. 1.16.4, ART for Windows takes long time (more than 4 or 5 minutes) to open Raw files at least Nikon NEF or Olympus ORF formats. Non-Raw files opening is OK, but when there are not any existing thumbnail images, it seems that ART cannot make thumbnail images from Jpeg or TIFF files (I use Lazy caching option for thumbnail images.). No problems are found in Ver. 1.16.3.
Do you have any ideas for these problems?

Can you post one of such files? Did you try also 1.17?

In 1.17, the situation is same.

2022年11月29日(火) 14:56 Alberto via discuss.pixls.us <noreply@discuss.pixls.us>:

_DSC0074.NEF (22.9 MB)

Thanks – as you might imagine, it works fine here :frowning:
Can you try setting “exiftool path” to the empty string in preferences and see if that changes anything?

Thank you for your advise, but nothing has changed.

Hello, I have faced same problem as yasuo san (I also Windows 10 (home) 21H2).
But I have found that it can be solved by this:

  • Changing language settings of ART from Japanese to English.
  • Changing regional format settings of Windows from Japanese to English.
    (Settings → Time & Language → Region)

I guess the problem is related to double byte characters.

thanks to both for the additional information.
What I find strange is that nothing should have changed wrt. 1.16.3, at least not in ART. I might have upgraded some library in the meantime though. If you still have the 1.16.3 installer somewhere, can you post a link to it? (I think I have deleted it locally, unfortunately…)

Update: I have changed my language settings to Japanese, and now I can reproduce. I will try to understand what is going on – thanks for the help!

1 Like

Thanks for additional information.

I also tried to install ART to other PCs. One is installed Japanese Windows 10 21H2, and one is installed 22H2. In 21H2 PC, I found same problem, and In 22H2 PC, it seems working well. So it may be UTF-8 based Windows 21H2 proper problem.

Anyway, I uploaded 1.16.3 install file in following link.

Maybe some ideas: Japanese installations of Windows 10 1903 and later might already be running in UTF-8 default encoding everywhere, while most others are I think still using the usual wide char (UTF-16): Use UTF-8 code pages in Windows apps - Windows apps | Microsoft Learn and https://helpcenter.nshift.com/hc/en-us/articles/360016886479-Errors-caused-by-Windows-10-Unicode-UTF-8-encoding

Hi @yasuo and @S.Honda, can you try this version and see if it works better? (Just unpack it somewhere and run ART.exe)

it seems problems solved. Thank you!

Good, thanks for testing! I’ll make a 1.17.1 release then

I also confirmed the problem solved in newer version. thanks!