Release of G'MIC 2.8

@David_Tschumperle Could you make 2.8.4 pre available for Window CLI?

It’s currently being built. Should be available in 30-40 minutes or so.

OK, uploaded Windows version.

Hi, not sure if the correct place to ask, if not please redirect me. I am using G’MIC-QT 2.7.3 with Gimp 2-10 on Mac OSX10.13.6. In update information I get the message that a new version of G’MIC plug-in is available. Went to the G’MIC site download page, downloaded the latest, but after installing I still have the same 2.7.3 version. Does it means that the Mac plug-in is not yet updated or that I am doing something incorrectly?

I don’t manage G’MIC-Qt for Mac, but maybe @KaRo or @Carmelo_DrRaw could help for this.

You are quite right! Still have a look in Hello all,I have a question!!!

I think @Carmelo_DrRaw is still busy.

@zurdo

I am still working in porting my macOS Travis-CI scripts from homebrew to macports, because it provides better binary dependencies.
I’ll focus on that during next week, hopefully I will be able to provide again up-to-date macOS packages by next Friday…

Thanks for all the quick answers, and for all the work you guys are doing here.

@David_Tschumperle Are you doing those manually? Maybe @Carmelo_DrRaw could help automate that (Win CLI, etc.) too?


I noticed a change in the behaviour of help. Before I could do something and still get output like

gmic h equalize
gmic sp tiger h equalize
gmic sp tiger h equalize[0] # ?
gmic sp tiger h +equalize   # ?

The first one still works as it should. I believe the second one worked before but doesn’t now. Not sure about the other two. Anyway, I don’t mind but I find the three other use cases convenient, and I instinctively insert the h expecting help output. :crossed_fingers:

Yes, there have been changes for command help lately.
There was actually a bug : the pattern h command were seek on the command line, and if found, the help for the command was displayed.
But, this was also working in (rare) cases where the help was actually not requested, like in this example:

$ gmic 256,256,1,1,255 text h blur 10

^^ Here, I wanted to draw a “h” in the image, not displaying the help for blur ! ^^

I agree that this is unlikely to happen, but still, these cases don’t have to be misunderstood by the interpreter.

I’ve pushed a small fix a few minutes ago in the update file, so with $ gmic up , this could solve your problem. Let me know.

  • 2020/02/10 : Release of minor version G’MIC 2.8.4.

Seemingly command help in gmic cli does only print help texts starting with #@cli from the file update290.gmic, not from any other command file neither $_path_user nor any one loaded with command m?

Possibly it makes sense to add another parameter, the gmic file name, in command help, similar to my changed help command?`

#@cli kr_help : command : (no arg)
#@cli : Display help (optionally for specified command only) and exit.
kr_help : skip ${1=""},${2=1},${3=$_path_rc/update$_version.gmic}
if isfile([’$3’])
l[] cimgz:$3 k[0]
onfail l[] raw:$3,uchar k[0] onfail endl
endl
if $! k. fi
fi
if !$! return fi
y a y
+_help $1,$2 k[0]
if narg(${}) _help[0] ${},0 fi # In case of shortcut, display also help for shortcut command.
rm v 0 q

help worked in 2.8.4 for commands in files other than update***.gmic, or am I misreading your problem?

Hmm, at least not with my 2.8.4 from custom commands only in $_path_user!

I’ll try to fix that ASAP.

It should be working now, with latest source in git repo.

Am I right, that now the help command works for update290.gmic and $_path_user?

Wth command <file> loaded functions I still get no help! Seemingly there is no way back to the source? Hmm an uncommand <file> to remove all functions in that <file> wouldn’t be bad either, than there might be a pointer to the source with comments too?

By the way:

gmic uncommand * ${_path_rc}update${_version}.gmic $_path_user

deletes 4181 commands and reloads only 4180!

[gmic]-0./ Start G’MIC interpreter.
[gmic]-0./ Discard definitions of all custom commands (4181 commands).
[gmic]-0./ Input custom command file ‘/Users/karo/.config/gmic//update290.gmic’ (4040 new, 27 replaced, total: 4040).
[gmic]-0./ Input custom command file ‘/Users/karo/.gmic’ (140 new, 3 replaced, total: 4180).
[gmic]-0./ End G’MIC interpreter.

@David_Tschumperle A ton of my filters just broke after the recent update. I believe these worked fine before today.

  1. Binary Alternating Quaddro Texture [Multichannel] is broken.
  2. Brick no longer shows the preview of bricks
  3. Color Modulo Texture shows a error
  4. Construction Material Texture shows nothing useful
  5. Fibonacci Texture broke.
  6. Premade Palette broke
  7. Transfer Color[Reduced Colors] broke
  8. Brick lost it preview

You are talking about 2.9.0_pre ?

1 Like

Yep, that is what I’m talking about.