Release of G'MIC 2.8

Great, that works. Just have to redirect the standard console now.
Thanks

  • 2020/01/14 : Release of version 2.8.2.
2 Likes

David, is it possible to extend quadtree variations even further to create additional quad-like patterns?

Can the math parser multiply whole vectors and perform similar operations? That would be useful for my kaleidoscope layer cake script.

I think you can. Like this? See the vector thread made by @David_Tschumperle.

A=[3,4,5]
B=[5,4,5]
C=A*B
C Output: 15,16,25

That’s cool. Now I have to figure out some other problem with the overall script. I’ve made a thread about my efforts here: Kaleidoscope Layer Cake problems

Just some minor remarks to the latest version 2.8.3 and 2.8.4_pre:

1- I miss ‘struppercase’:

~ $ gmic h struppercase

gmic: GREYC’s Magic for Image Computing: command-line interface
(https://gmic.eu)
Version 2.8.3

    Copyright (c) 2008-2020, David Tschumperle / GREYC / CNRS. 
    (https://www.greyc.fr)

struppercase:
    string

~ $ gmic struppercase aBcD3F e ${}
[gmic]-0./ Start G’MIC interpreter.
[gmic]-0./ Input file ‘struppercase’ at position 0
[gmic]-0./ *** Error *** Unknown command or filename ‘struppercase’ (did you mean ‘strlowercase’ ?).

  1. What about latexing the reference file gmic_reference.pdf with hypertext? I think that would be quite helpful for navigation!
  1. https://github.com/dtschump/gmic/commit/de763e1a5ce3d898aa856feaf8ad369cdcdd2bf4

  2. I think the links are removed by the script that tries to compress the .pdf file a little bit. Will check later.

Very good, thank you for the struppercase.

Still some remark to the gmic_reference.pdf:

The selected font for command lines, eg

Example 701 : 500,500 repeat 10 +noise poissondisk[0] {3+$>} done rm[0] a z f “!z?(R=cut(norm(x-w/2,y-h/2)/20,0,d-1);i(x,y,R)):0” slices 0 to rgb f “max(I)?u([255,255,255]):I” blur radial 0.6% equalize n 0,255

cannot be used easily by copy and paste. One can see that for noise_poissondisk the underscore is lost, similar to blur_radial. Sometimes there are also other characters not recognized, like ”. Maybe there is another font possible?

Feature request I would like display to show the zoom percentage and have the option to set zoom to 100% for selection.

Minor issue (2.8.4_pre):

“gmic version up” does not show any update message

“gmic version image.jpg” neither gives any message of image loading nor displays the image.

Seemingly “version” switches verbosity and something more!

That is correct, and that should be fixed now (need recompilation from git develop).

Very good, its corrected!

1 Like

For those who may be interested, my current workaround is to add a slice to the image. This would change the CTRL+R behaviour to resize a zoomed view to 100%.

Another minor thing:

gmic sp ?

[gmic]-0./ Start G’MIC interpreter.

[gmic]-1./ Input sample image ‘gummy’ (1 image 750x500x1x3). (1 image 0x0x0x0).

[gmic]-2./ Display images [0,1] = ‘gummy, }’.

[0] = ‘gummy’:

size = (750,500,1,3) [4394 Kio of floats].

data = (190,190,190,190,195,190,190,190,195,195,199,195,(…),213,213,217,213,213,221,209,209,213,213,213,213).

min = 0, max = 254, mean = 189.267, std = 73.9949, coords_min = (250,119,0,2), coords_max = (338,313,0,0).

[1] = ‘}’:

size = (0,0,0,0) [0 b of floats].

data = () [float].

[gmic]-2./ End G’MIC interpreter.

Where does the empty image [1] come from?

I don’t get that in Version 2.8.1. PS Tried it on 2.8.3 just now. It works as expected.

Hmm, I have tried it with 2.8.3 and 2.8.4_pre on Mac

It looks like something else is broken. I.e.,

[afre]^_^) log2: Transform imageb? into log2 space.
[afre]^_^) gui1: Blur image&? with a custom guided...

Should be

image [0]

etc.

PS stdlib command example

gmic sp tiger,flower remove_duplicates
Remove duplicates images in selected list of image

No text after list of image.

Yes, I have something similar eg in “append_tiles”

[gmic]-2./ Append image2? as a 2x1-tiled image.

Bug confirmed.
I’m currently investigating.