Release of G'MIC 3.2

What is your input image?
Image made in Gimp 1920*1080 .

It works on 3.2.0 here. I’ll have to check 3.2.1.

Even 3.2.1 worked. I updated.

I’m not really sure why some does not work. Is it possible I run out of memory?

I tried with 3.2.2 (pre-) and it worked

3.2.2 Hard sketch doesn’t work

@hover that’s the exact same error as the one you got for the Pencil Portrait filter.
Just curious, do you have a custom user.gmic file that would redefine some of the default command ? That could explain this.

do you have a custom user.gmic file that would redefine some of the default command ?
No, I don’t have.

I pushed changes to fix these, can you verify?

EDIT: Okay, both got the Q erros fixed. JFIF (JPEG) Encoder seem to have something’s up, but almost works. JFIF Effects now has invalid selection[G] error. I made a push to fix that.

Is it possible for Make squiggly to add random sizes of squgglies? From small to big.

Could you also get Mondrian pattern in Gmic ?

Mondrain Pattern is on my list of TODO. And I have a lot of those. I’m just doing small fixes and so. And I still have to finish the upgraded Picture Mosaic.


Je pense que la version GMIC 3.2.2 pour GIMP 2.10.34 est instable. Cela concerne la version pour Windows, j’utilise toujours le module d’installation en exe. Une fois installé, pour reproduire l’erreur :
-Charger une image jpg taille 1920x1080
-Charger une deuxième image en tant que calque
-ouvrir GMIC et utiliser Stylize avec réglages par défaut vers un nouveau
-Un troisième calque se crée donc.
-effacer ce troisième calque
-Essayer de relancer GMIC avec le menu “réafficher le dernier filtre”
-Cela donne une boite d’erreur, le greffon GMIC s’est arrêté.
Environnement Windows 10 Pro à jour
C’est tout ce que je sais.

Encore merci pour avoir développé GMIC. c’est un MUST.

G’mic-3.2.2 for Gimp-2.10.34 only needs 8 dlls.
The others are in the bin directory in Gimp.
It works very well without being messy with too many duplicate files.

Gmic-3.22 and Gimp-2.10.34 Win10_64bit

The problem is that it happened in the past, for some older versions of GIMP, that the .dll files were not installed, so if we didn’t ship them with the installer, people installing the plug-in were not able to open it.

It’s not a problem of being messy or not, it’s a problem of ensuring a minimal set of dll files that makes the plug-in work everywhere and for every version of GIMP 2.10.
No one has succeeded to provide us with such a list BTW.

It would be nice if it could work like that.
An example attempt to run Gmic-3.2.2 in Gimp-2.10.5 gives this error:


This has been noticed also by @samj .
So far, we didn’t succeed in reproducing the bug on our Windows VM, so we are working with @samj (many thanks to her!) to investigate this bug.
While waiting for the problem to be solved, I have set the Windows installer to the default version 3.2.1, in the download section of the G’MIC website.

What I feared is finally happening… I should have listened to myself…

I’ve curated the list of .dll files shipped in the .zip archive and the installer, when I reinstalled my build environment on Windows. But it seems there are case where those .dll are not enough.

How the hell did we end up with this recurring .dll problem in Windows?

Newest version (zip) works for me, David; not sure about older versions of GIMP. Sad such a situation exist; makes it hard to distribute software for sure. :slight_smile:


There is no DLL problem with Gimp-2.10.34 from

For those who have a lack of DDD use those of Gimp-2.99 64 Bits contained in the archive :

Even better, update your GIMP version :o)

just for the sake of testing:

  • installed Gimp 2.10.32 on Win10
  • installed Gmic 3.2.3
    • Missing: libicuin72.dll, libicuuc72.dll, libpcre2-16-0.dll
  • updated Gimp to 2.10.34, leaving Gmic as is
  • no more complain, it just works.
1 Like

Hello @David_Tschumperle

Just tested on Windows 11 with GIMP 2.10.34.
No problems so far :slight_smile:

Thanks a lot for your software. It is indeed amazing :slight_smile:

1 Like