Stupid color management/Distro question


(Mica) #21

I too find Anaconda, the fedora installer, to be a bit confusing.


#22

W-e-l-l, I would not know, because fedora hangs when
Gnome display manager wants to manage things.
gdm clearly does not like Nvidia (which is the gfx I have).


(Colin Paul Adams) #23

I have never had problems with my Nvidia card and I’ve always used fedora (with gdm).


#24

I am not sure what that is supposed to mean…
Colors management tools are available on any DE.
Do you mean XFCE’'s default image viewer has no color management?


#25

Thank you, Colin. That is odd!
Some other theories why it hangs include
Wayland, or perhaps the Ryzen CPU,
or perhaps the 4K UHD monitor, or…


(Colin Paul Adams) #26

I thought Nvidia wasn’t supported with Wayland?


#27

It seem like you have two problems, finding a distro that runs Ryzen 7 , which is quite new and also which desktop is best for colour management. I am running Ryzen 5 with integrated graphics on Debian sid, as Siduction, this also ensures the latest versions of applications. Any distro with a recent kernel, ( >4.17) mesa and amdgpu driver should work OK. I don’t know how you set your colour profile but using Colorhug https://hughski.com/index.html will calibrate your monitor and generate a profile you can use for your system. I don’t think there should be any difference between any of the desktops, GTK and Plasma work fine together and all apps will run on any distro.


#28

some apps such as darktable more or less depend on colord or xatom. XFCE has no gui for configuring colord or xatom


#29

have you ever tried manjaro? I think it has a very new kernel and if not you can easily (bot do not ask me how) get one


#30

Yes. I am presently on Manjaro/KDE. Works fine.


#31

You could switch to Manjaro Gnome, if you want Gnome. But KDE is probably better for the 4K display.

I tried Fedora in a virtual box yesterday. The iso did not boot when I activated EFI. Maybe I will try it with Vmware.


#32

Could you use display CAL


#33

my experience is that the system forgets sooner or later which profile was set with Displaycal, so setting a profile with displaycal does not work properly


#34

I installed Fedora now in Vmware - does not boot. I think it is because there is no EFI partition.


#35

Hi Anna & thanks.
Actually, I do not think that that is my problem.
I cannot even boot fedora from a Live USB stick!


(Isaac Ullah) #36

Try Pop!_OS by the System 76 folks. Runs Gnome 3 and comes with great hardware support baked in. Installed it on a new Lenovo laptop recently, and I’m really liking it. CMS seems very good thus far…


#37

Thank you. Will try…


#38

why aren’t your satisfied with Manjaro?


#39

Oh, but I am very satisfied with Manjaro/KDE.
But I have been smitten by Distro Fever since the
mid-1990s – and since I read about Richard Hughes’
work with fedora, I was eager to test it.


#40

I thought he just works for Red Hat, his Colord and other colour related work will run on any modern distro and any desktop it is not Fedora specific.