Welcome the Siril Project!

:no_mouth: Never seen that before. I don’t know what is going on …

@gaaned92 your build works fine here though (as you wrote) icons are missing

Screenshot of your build

Screenshot of my build

1 Like

I have a brand new W10 VM, I’m going to install MSYS2 on it and see if I have the same issue.

  • Now if I launch from a mingw64 shell, the GUI is ok. There was missing a few UI elements (schemas…, adwaita.).

  • But If I double click on the exe, I have the same window as above.
    searching! mingw64 shell surely provides access to mingw64 resources.
    If I use a MSYS2 shell I get a lot of warnings and also borked window.

  • Siril doesnt use the adwaita scalable icons. @heckflosse @TooWaBoo can you explain why from ages ago, RT uses only scalable adwaita icons on Windows?

  • siril searches for a “scripts” directory. What to do?

  • 3 fonts are missing

Some script paths are set in parameters. It is normal that siril only find one at first use. You can enter your own path in preferences.

The missing fonts are used in the main svg icon (logo) . I m not sure that is important

Scripts in Siril are a way to run a sequence of commands. They are optional.

I know nothing about fonts and UI elements problems, sorry. We don’t develop with windows, so we are not sure about how to correctly handle these items, we mostly hope that GTK+ will be portable…

Thank you all for your great help! We’ve been there one day, and we already have several contributions!

The “production” logo should probably have the fonts outlined. I can take a look.

Whoever designed the logo, BTW, did a nice job. The website design is also very nice :slight_smile:

3 Likes

After installation I have the same bug when I run siril.exe
image
But, when I run Siril in command line I get this message:
$ siril
C:/msys64/mingw64/bin/siril.exe: error while loading shared libraries: libtiff-5.dll: cannot open shared object file: No such file or directory

$ pacman -Ss libtiff
mingw32/mingw-w64-i686-libtiff 4.1.0-1
Library for manipulation of TIFF images (mingw-w64)
mingw64/mingw-w64-x86_64-libtiff 4.1.0-1 [installé]
Library for manipulation of TIFF images (mingw-w64)

You could look at setting up a CircleCI, Travis-CI or AppVeyor build process all offer free personal accounts & with a little digging you can get a FOSS account with more credits/time.

With such an account you can build for Linux & Windows (and Mac on AppVeyor “coming soon” on CircleCI).

If you are using GitHub or one of several other hosting services you can have builds triggered automatically on commits to the project or to specific branches of the project. It is also possible to have your GitHub/other project display a build status flag automatically.

2 Likes

Hello.
Thanks for your message. Yes I know circleCI. I even have an account. I also have a macos script that provides a dmg automatically. However for Mac I need (at least for now) to purshase a paid account.
Also, now our code are on gitlab and circleCI is only compatible with github. So it is easier to do everything linked to the main repo IMO.

@heckflosse I think you have Mingw64 in your path. I think there is something in /mingw64/bin that is required, but what?

@argonothe libtiff-5.dll is copied in /mingw64/bin when installing mingw-w64-x86_64-libtiff 4.1.0-1. So it should be in the same directory!

For libx264, you have to downgrade the package: see post above

I think that in the next future we need to use meson instead of autotools. I’ve seen we can use meson in Visual studio, that could be great.

I found the missing dll: libcroco-0.6-3.dll
It is surely called at run time and not at start time.

I am going to generate a complete build to test.

2 Likes

Thank you :slight_smile:

Hello. Quick question: is there a PPA with nightly builds?

The latest release from Nov barely fits my 2560x1440 display without running with GDK_SCALE=1.9. I never got to filing a bug report, but now I see you redesigned the UI and I’m interested to try. The amount of deps is a tad too much for me to build from git.

Hello.
There are PPAs, but not of nightly build. I manually update when there are some interesting changes :slight_smile:

This is my first Siril build for Windows. Please test as I am not able to do.
siril_master_0.9.12-292-g87acce9c_200122_W64_release.7z
uploaded at
https://keybase.pub/gaaned92/SirilNightlyBuilds/

edit:
siril_master_0.9.12-317-gfb66dc7d_200126_W64_generic
uploaded at same place

2 Likes

I wonder if it could be interesting to have G’MIC filters in Siril.
In G’MIC, we have pretty decent deconvolution and denoising filters among other things (also a few things for image registration and stacking). Just a wild guess !

Every ideas like this are interesting :).

I tried to build float branch. It failed on libRTprocess as there is no makefile generated.

I think one easy way is to consider librtprocess as an external dependency. (There should be no difficulty on MSYS2 as I build it and install in Mingw64, neither on Linux. )
When building siril, one first step could be to build librtprocess (CMAKE, make, make install in a local siril subdir) .

With the autotools, what is the way to perform an out of source build? (https://gitlab.kitware.com/cmake/community/-/wikis/FAQ#out-of-source-build-trees)