Win 32 Build Please?


(darix) #22

one more reason to think about upgrading: seems 32bit systems are not fixed yet for the meltdown/spectre bug.


#23

I tested on w10 and it worked.
Could you set verbose=true in option file, run rawtherapee from a console and paste messages in a file and attach it.
I will have a look at end of we when back home


#24

Hi gaaned92,

I added the line “Verbose=true” in section [General] in file “options” for both installations 5.2 and 5.3-549-g42d0f550. Then I opened the command box, and started RT. No verbosity in both cases.

For 5.2 I get this in the command window, 5.2 starts normal:
C:\Programme\Foto\RawTherapee_5.2>rawtherapee.exe

C:\Programme\Foto\RawTherapee_5.2>

For 5.3 I get this in the command window, 5.3 doesn’t start:
C:\Programme\Foto\RawTherapee_5.3-549-g42d0f550> rawtherapee.exe
C:\Programme\Foto\RawTherapee_5.3-549-g42d0f550>

Then I immediately get this error message box:
Title: Microsoft Visual C++ Runtime Library
Message: This application has requested the Runtime to terminate in an unusual way. Please contact the application’s support team for more information.

Let me know, what else I could try out.

Regards


#25

@RawTherapist

What is your system please

Some informations were missing from my post

  1. be aware that for RawTherapee_5.3-549-g42d0f550, the option file is located in
    %localappdata%\rawtherapee5-dev
    that is
    C:\Users\<user>\AppData\Local\rawtherapee5-dev
    for stable 5.2 that should be
    C:\Users\<user>\AppData\Local\rawtherapee

  2. when running from console, type
    rawtherapee.exe >log.file to get the log file. that should work (tested here)


#26

Hi gaaned92,

my system is Win 7 Starter 32bit, with Intel Atom.

I only find this folder: C:\Users\AppData\Local\rawtherapee
Can’t find the folder C:\Users\AppData\Local\rawtherapee5-dev.

When trying to run “rawtherapee.exe > RT_log.txt” from cmd, I get the message “Access denied”.

Maybe I should try again with a RT non-dev version.


#27

Hi gaaned92,

is there any news or progress with a Win32 edition of a modern RT version?


#28

@RawTherapist

I tried again recently but was again unsuccessfull.
If by chance a dev (@heckflosse, @floessie or @agriggio) is willing to help me to build a W32 development build, I can try again.

But I would say that the best should be to go the 64bits way to get the max from RT.


(Flössie) #29

André, could you open a GitHub issue, so we can discuss the W32 problems there? I can’t help you with Windows specific problems, but maybe with the 32b ones…


#30

Just to let you know that there is at least one more person out there who still uses 32 bit Windows (Win 7), and intends to do so for at least 1 1/2 more years :slight_smile:


#31

RawTherapee_dev_5.4-134-g840908e4_WinVista_32.zip

uploaded at
https://keybase.pub/gaaned92/RTW32NightlyBuilds/

Can you test this build?


(Ingo Weyrich) #32

Though usage of 32bit OS decreases for reasons (at least in the highly industrialized, rich parts of our planet), there are other parts on our planet, where people still have to use 32 bit OS. For that very reason, I highly appreciate 32 bit builds of RT.

@gaaned92 You have my full support for this!


(Glenn Butcher) #33

Actually, Windows XP is probably most prevalent in the “highly industrialized” regions, because that high industrialization relies in large part on process controllers that are still paneled with XP computers. If you find yourself walking through a power plant sometime, if you encounter a touch panel, it’s probably a WinXP computer. Slow to upgrade; once something is working correctly in this world, the motivation to change is pretty small.

Absolutely nothing to do with image processing…


(darix) #34
  1. Sure many companies are still stuck on old windows version. but those are usually in a secured environment. not directly connected to the internet or still being used for accessing the internet
  2. Even those protected environments are sometimes not protected enough …

So as soon as your OS runs out of vendor support, you want to switch to a supported version again. And that is actually a chance for linux to jump in, if people don’t have the money to buy the next Windows version. Windows 10 even had free updates from older windows versions.


(Ingo Weyrich) #35

Agreed!


#36

@gaaned92:

Thanks for the build. I installed RawTherapee_dev_5.4-134-g840908e4_WinVista_32.zip. Installation went fine; however, when starting RT, it aborts with an error message from “Microsoft Visual C++ Runtime Library”: “The application has requested the Runtime to terminate it in an unusual way”. That happens before anything is displayed on screen.

OS is Win 7 Professional 32bit.

Best regards
Bezier


(Karlheinz Lehmann) #37

Hi, maybe this link can help you http://rawpedia.rawtherapee.com/How_to_fix_crashes_on_startup


#38

@Bezier
As it doesn’t crash on my system, could you generate a back trace as described in https://rawpedia.rawtherapee.com/How_to_write_useful_bug_reports

Note: all the required tools are included in the build (gdb.exe and rawtherapee-debug.exe)

If you have problems to do that, don’t hesitate to ask.
Once done, I will open a ticket on rawtherapee github


#39

@gaaned92:

I followed the instructions. However, no info was displayed and no log.txt created (at least not in the RT directory – do I need to look somewhere else?).

This is the information from my command prompt:

[…]
Reading symbols from rawtherapee-debug.exe…done.
(gdb) r
Starting program: C:\Program Files\RawTherapee\5.4-134-g840908e4\rawtherapee-deb
ug.exe
[New Thread 5868.0x1e50]
[New Thread 5868.0x1b6c]
[New Thread 5868.0x1af8]
This application has requested the Runtime to terminate it in an unusual way.
Please contact the application’s support team for more information.
[Thread 5868.0x1b6c exited with code 3]
[Thread 5868.0x1af8 exited with code 3]
[Inferior 1 (process 5868) exited with code 03]
(gdb) set pagination off
(gdb) set logging file log.txt
(gdb) set logging on
Copying output to log.txt.
(gdb) info threads
No threads.
(gdb) thread apply all bt full
(gdp)

Does this help?

Best regards,
Bezier


#40

To continue: I got adventurous and built RT myself, following the instructions in RawPedia. Building went through with a few warnings and notes after “In file included from D:/Software/RAWTherapee_Source_dev/rtengine/dcraw.cc:85:0:”. I can give you the details, if that’s interesting for you.

However, when running from MSYS2, it stops with a Segmentation Fault after a second or so, before displaying anything else. When running from Windows Explorer, it also stops after a second or two, without any error message.

My machine is an Acer Travelmate laptop with Core2Duo processor, about 10 years old, with Win7 Professional 32bit. The official “RT 5.0-r1-gtk2 for Windows XP or newer 32-bit - fast” from the RawTherapee website runs fine. (So, thinking about it, maybe GTK3 is the problem?)

I have no experience whatsoever building software under Windows, and haven’t done any serious programming for more than 20 years, so I guess I’ll leave it at that.

However, I think there are 3 errors in RawPedia that I’d like to let you know about:

  • pacman -S should include a lensfun package for the 32bit version, too.
  • libgcc_s_seh-1.dll does not exist; should be libgcc_s_dw2-1.dll.
  • libfribidi-0.dll is needed but missing in the list.

If I can do anything to help find the problem, please let me know. Otherwise, I’ll just have to wait until I buy a new machine, in 2020 or so…

Best regards,
Bezier


#41

@Bezier
As I was out of home, I didn’t notice your preceding post. Sorry for that.

The first two errors are tied to the 32 bits build process that is no longer updated on rawpedia
The last is a new requirement from last MSYS2 update

The problem with XP is due to the window manager incompatible with GTK3.
Vista is the first system with the new window manager.

The problem comes from a commit that broke W32 build.

So before trying to debug, if you are patient, I will try to find where it happened. Perhaps @floessie or @heckflosse know that.

I am going to build different versions which Iwill upload at
https://keybase.pub/gaaned92/RTW32NightlyBuilds/

For each version please indicate if it is good or bad

1- RawTherapee_5.3_WinVista_32.zip