3 file-* crashes when starting up GIMP v2.10.38 in old macOS Mojave v10.14.6.

I installed GIMP v2.0.38 in my old 13" Intel MacBook Pro’s macOS Mojave v10.14.6. However, I get three crashes after starting GIMP up from file-tiff, file-ps, and file-pdf-load as shown in my https://i.redd.it/y8r40xftwwyc1.png screen shot/capture. I already tried deleting my /Users/ant/Library/Application Support/GIMP to reset GIMP’s settings back to defaults, but that didn’t help. Is anyone else having this problem too?

Thank you for reading and hopefully answering soon. :slight_smile:

Can you post the information from clicking the Report… button?

I’m looking thru the package and noticing libzstd is built against macOS 13 instead of 10.13.

otool -l /Volumes/GIMP\ 2.10\ Install/GIMP.app/Contents/Resources/lib/libzstd.1.dylib | grep -e sdk -e minos
    minos 13.0
      sdk 13.3

That’s going to cause a problem loading those modules which likely in turn load that particular compression library. In the meantime I’ve opened the issue macOS package: libzstd.1.dylib is built against macos 13.3 instead of 10.13 (#11483) · Issues · GNOME / GIMP · GitLab

1 Like

http://zimage.com/~ant/temp/3appleReportsForGimp2.10.38inMacOSmojave10.14.6.zip for Apple’s report crash logs. Please kindly let me know when they are not needed anymore so I can delete them. :slight_smile: GIMP - Downloads says "… Warnings and information

  • Supported OS: macOS 10.13 High Sierra or newer…"

I also tried to make a new account on https://register.gitlab.gnome.org/, but I never got its e-mail to confirm my registration. :frowning: I am waiting for an answer from sysadmin@gnome.org. I did get its automated ticket e-mail answer.

You may delete them now, this is the part we need: it shows libzstd.1.dylib not loading.

Termination Reason:    DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: @rpath/lib/libzstd.1.dylib
  Referenced from: /Applications/GIMP.app/Contents/Resources/lib/libtiff.6.dylib
  Reason: no suitable image found.  Did find:
	/Applications/GIMP.app/Contents/Resources/lib/gimp/2.0/plug-ins/file-tiff/../../../../../lib/libzstd.1.dylib: cannot load 'libzstd.1.dylib' (load command 0x80000034 is unknown)
	/Applications/GIMP.app/Contents/Resources/lib/gimp/2.0/plug-ins/file-tiff/../../../../../lib/libzstd.1.dylib: stat() failed with errno=1
1 Like

Thank you for the quick answers. Now, I have to go find the old version’s installer and reinstall it. :frowning: