a noob question: camera preset is not working correctly

I’m very new to Darktable, so I apologize if I’m doing something wrong or the question doesn’t make sense. I have a Nikon D7500 camera. When I copy RAW files to my computer, they look fine in my standard image viewer gThumb, for example:

However, when I open the same image in Darktable for the first time (with no .xmp file), it looks very discolored, as someone has greatly reduced saturation:

I played with some various buttons and slides around and found that if I go to “base curve” and change “preserve colors” setting from “luminance” to “none”, colors become much closer to real:

By playing with different curves and settings I can eventually tweak the colors to my liking, but it takes time and it seems odd that gThumb automatically gives me the right colors. This happens for every single image.

Question 1: Is incorrect “base curve” setting indeed the culprit here? Does it make sense to have “none” as default setting instead of “luminance”? The base curve is automatically set to “D7500” based on EXIF data.
Question 2: Even when I change the “preserve colors” settings to “none”, the colors are still not quite right. If you look closer at the example above, you can see that the cow has a weird green-ish color in Darktable compared to much more realistic brown color in gThumb. Note how RGB histograms are very different in Darktable vs gThumb. What other settings should I tweak?
Question 3. Is it possible that the default base curve for D7500 is wrong? How do I check that? Would it make sense to go through about basecurves | darktable to calibrate a custom base curve?
Question 4. How do I configure Darktable to automatically apply the same settings that gthumb does? It would save me a lot of time on manually fixing incorrect colors.
Question 5. Could this be caused by wrong settings somewhere else (camera, monitor, OS etc)? Seems unlikely to me because gThumb gets the right colors.

Camera: Nikon D7500 (with latest firmware 1.10).
Software: Darktable 3.0.1 compiled from source code. I have “auto-apply per camera basecurve presets” set to “on” and it seems to work (auto-select “D7500” curve).
OS: Ubuntu Linux.
AFAIK gThumb uses libraw to process RAW images. Where does libraw get base curves and other settings?


Maybe gThumb just displays the embedded jpeg. Try the linear workflow (higly recommended introduction: darktable 3.0 for dummies (in 3 modules) )
Or spend some time with the video in Basic semi-automated style for darktable 3.0/filmic for a one size fits it all (or almost all) approach


gThumb is likely using the embedded jpeg, which is a processed image. Your barely processed raw file should look flatter and have less saturation, that is a good thing. You need to add a few modules to get it looking acceptable.

1 Like

You are absolutely right! I didn’t realize that NEF file also contains a JPEG inside. I used “dcraw -e” to extract the JPEGs from NEF files and they look exactly like what gThumb shows. Interestingly, if I zoom in to 100% in gThumb, it shows the actual raw image and it has exactly the same washed out colors as Darktable. So I guess my question is how to get the same colors as out-of-camera JPEG? Is it possible to reconstruct the curves (base curve, white balance settings etc) given a series of NEF and matching JPG files?

Thanks for the links to the tutorials!

Forget about the out of camera JPEG, construct your own style.
I was trying to do the same kind of error some months ago, but I let it go.
Start with the above mentioned links, create your own presets that applies to all raw images you load and go from that to apply further modifications.
Now a day, I only use the out of camera JPEG to have a general feeling about the scene, and sometimes to give me an idea of the actual contrasts and colors of the scene.


Basecurve is depreciated since sometime in darktable. The above linked article about howto create basecurves dates back to 2013. The best is to follow the advice given by @MStraeten and @Oleastre.

If you want to replicate OOC JPEG you need to use the program shipped with your camera.

If.you want to match the SooC jpeg, see darktable-chart, but I’d agree with others that your own style will be so much better.

1 Like

Just to add my $.02 worth, if you want to see an out of camera jpg, even if you used raw only when shooting, you can put the card back in the camera, go to the retouch menu, and scroll down to “NEF(RAW)processing.” Select the file you want and the settings you’d like. It will create a jpeg and add it to the card. If you shoot raw only and have no access to a photo editor, you can produce an image using the camera itself. I haven’t used this method much but it does work in a pinch.