Accelleration 3D


(Gabriele ) #1

Hi All,
is there a way to enable OpenCL in gimp??

Cheers


(Morgan Hardwood) #2

GIMP 2.9.6:
Preferences > System Resources > Use OpenCL


(Gabriele ) #3

Hi Morgan,
thanks for reply but
I have Gimp-CCE from Elle Stone and I’m non able to understand which versions I have: when Gimp starts it shows a splash with 2.9.5 but if I try into about menu it says 2.9.7…and into System Resource there isn’t that sentence.

Cheers


#4

@dafrasaga There should be a commit value. I usually go by that when comparing versions.


(Pat David) #5

You can also ask @Elle if she might be around (and has time).


(Elle Stone) #6

Hi Gabriele,

OpenCL is completely disabled and unavailable in GIMP-CCE for reasons given in Section E1 #6 of this page: https://ninedegreesbelow.com/photography/patched-gimp-compared-to-default-gimp.html

Regarding the splash screen, my apologies, I haven’t updated the splash screen since 2.9.4 was released and GIMP rolled over to 2.9.5. The splash screen has no bearing on functionality and I never thought to ask anyone to make an updated splash screen when 2.9.6 was released upstream and GIMP rolled over to 2.9.7.

The GIMP CCE code is up-to-date with upstream default babl/GEGL/GIMP code through October 1, 2017, which is to say, the version is 2.9.7. My web page on building CCE is somewhat out of date wrt to when I last uploaded new code.

I’m not sure what you mean by “into System Resource”.

Best,
Elle


(Gabriele ) #7

I mean what Morgan said…

Best,
Gabriele


(Elle Stone) #8

Oh, sorry, you mean system resources in Preferences. I removed the option to enable OpenCl in Preferences when I removed the code for OpenCl. Otherwise it would be an option that didn’t do anything.