add module to the group not working

So as a newbie, what have I misunderstood? I left, right, double, hold-click on the + sign under a group to add a module but nothing shows up? And yes, I did a duplicate of the entire preset. And I have made a restart. And I have tried to see if it’s already a bug in GitHub.
Sigh, hopefully someone has an idea/solution…

Hi Jens!
Sorry, I might be being obtuse… but what part of darktable are you asking about? I’m a little confused :thinking: a screenshot of the thing you’re looking at might be an easy way to set me straight :smiley:

Are you talking about this?

If so, you can only edit a user generated module but not the default ones provided by darktable. The easiest thing is to create a copy and then edit it.

Ah - I thought I’d say ‘oh of course’ at some point. It works for me, although on my windows system at least, there’s one or two points about that interface that seem a bit unintuitive… but when I single click the + sign I get a drop down menu.

One thought, after duplicating the preset, have you actually selected the duplicate?

I’ve had what looks a bit like a bug, but might be a misunderstanding on my part, where I add a module to the quick access group but it disappears again. Never quite worked out what was going on.

Works for me …created a new preset then deleted some groups and added one called test add…threw in a few random modules…

Hope this description might help and not confuse.

Setting up your own modules list for in the darkroom view

  1. Click on the hamburger under the histogram and select manage presets
  2. Duplicate the default module layout you have opened and rename it to something useful
  3. Uncheck ‘show quick access panel’ if checked unless you want that group
  4. Optional: to add a new group click on the + icon next to module groups.
    a. Then click on the icon of the new group and change it to the icon and name you wish to have. I use this to make a favourites group.
  5. Use the arrow to move any group right or left if preferred
  6. Close the dialog and then to add or remove modules to the various groups do the following:
    i. To add modules to a group just right click on the group’s icon, select all available modules and click which ever module you wish to add.
    ii. To remove a module from a group right click on the group’s icon and right click on the module you wish to delete

Many thanks for all the replies, appreciate.
I’ve attached an image of my current situation. As you can see, new preset, new group but nothing happens when clicking on + (see yellow lines).

@Terry I’m confused, 6.i. right-clicking not the + sign? I can left-click and then I can change the icon (nothing happens when right-clicking).

I’m on a Mac mini M1.

I’m not by the PC at the moment, but it looks like you copied the All preset and then you are trying to add a module. I think that’s not possible since you already have them all. Try deleting a module from another group first.

I personally only have one group and only have the modules i normally use. I also keep them in the pipeline sequence.

Nope, deleted all module groups with only LR left and tried to add. Nothing shows up :frowning:
Nice suggestion though.

I booted the windows 11 system. 4.1.0+109~g4ea7e5d5c

It works. I copied the ALL preset and added a group and added modules to the groups (even repeating ones).

Reinstalled dt and still not working at my end. I’ll report the bug…
EDIT: old bug when in full screen mode:

Close this dialog that you have open. You right click on the icons when you are in the normal darktable view. I hope that now makes sense.


1 Like