After upgrade to darktable 4.6, imported images don't appear in lighttable

I just did a test, and I could successfully import a directory with 4 images, but not another directory that also has 4 images. Those two directories contained all the same format CR3 RAW files.

Can you expand the top bad and make sure nothing is selected?

your collections filter is using a different path then what you show in the import dialogue

1 Like

Thanks for the suggestions, but no luck. Nothing is selected in the top toolbar. (I even removed those filters altogether.) And the collections filter on the left is using the same path as what I imported.

Just to try to clarify, I can import individual subdirectories, as long they contain only a few images. But if I try to import the parent directory of those subdirectories (with recursive directory checked), it fails.

I ran out of ideas, so I deleted the library.db file and downgraded darktable back to 4.4.2. With the older version, import to library works as expected (except it’s not reading my newer .CR3 RAW files any more, but that’s a different issue).

I don’t know whether this is relevant:

No, it’s not freezing, it just doesn’t import any images. And given how many hundreds of directories I have nested under my images directory, disabling recursive importing is not really a practical workaround.

darktable 4.4.2 is not experiencing this issue. I have downgraded and will continue to work with the older version for now.

Unless someone can reproduce the issue, this downgrade, while solving your immediate problem, will not help develop a fix. Do not forget that darktable relies on users for testing.

I’ll see if I can try tomorrow, but I only have a laptop running Windows,with only a handful of Play Raw images on it.

This is likely this bug ([import module /sql] import additional directory causes dt to stall · Issue #15861 · darktable-org/darktable · GitHub). It is fixed in master in PR that found other issues (po/import job asynchronous by TurboGit · Pull Request #15894 · darktable-org/darktable · GitHub).

Can you find an image on your computer (outside of DT) and right click on it to tell it to open in DT. Does it then open in DT? Also make sure that you have selected all seven star ratings options to show all images. What OS are you using?


Sorry, I’ve already downgraded to 4.4.2, since I have to get a bunch of photos edited before the end of the year, so I can’t do that test any more. FWIW, I did have all ratings selected in the filter.

I’m using Fedora Linux 39.

I think a screencast/video would be useful. Also as per

it would be nice to see that too.

I’ve had similar issue - importing in 4.6 works for me only when the “recursive” directory isn’t checked. Importing looks as if it has been successful, but no images appear in the library.

However, importing folders one by one, without ticking :ballot_box_with_check: recursive directory works as expected.

Darktable 4.6 on Windows 10

1 Like

I have the same problem with 4.6 from Flathub (running Tumbleweed).

This is what it looks like:

I hit “add to library” and the dialog box closes and I get a “imported 61 images” message instantly. The images do not show up in the lighttable view. I do not have any filters activated.

Same for me.

Same for me. Mac mini M1.

what exactly is the issue with your M1: nothing is imported or just the images in substructures of the selected root directory aren’t imported?

On my Mac mini I have Mac and Debian.
My main system is Debian. I “copy and import” 4 images in a directory with no problem.
Going to Mac I try “add to library” but they don’ appear in lighttable.

hm, i can reproduce that contents of subdirectories aren’t imported via “add to library” but the content of the selected directory is imported.
That behaviour is fixed in 4.6.x branch - will build and provide my macos development packages focussing on 4.6.1 end of week …

It seem the recursive directory is the problem because selecting the actual directory
works fine.

Yes that’s it. Thank you.