Animated Spinning Globe Gap

I have created a 1080 x 1080 square image for generation of an animated spinning globe; however, then the filter is applied, the resulting globe has a gap in some of the frames.

WWR Flag Globe 2023

The gap can be seen about halfway through the animation. I have attempted to remedy by adding to either side of the source image to no avail. I understand that GIMP might not be the best way to do this, but I am trying anyway.

It’s because you have some transparencies at/on the edge on your original image. Go to Image > Crop to Content, to remove it.

Example of transparency at the edge:


After “Crop to Content” > No transparency at the edges


Last but not least… Why make a .gif instead of an animated .webp? (when exporting just put the extension .webp)

Advantages of animated WebP compared to animated GIF
WebP supports 24-bit RGB color with an 8-bit alpha channel, compared to GIF’s 8-bit color and 1-bit alpha. Thus webp keep the true color and smooth transparency, also Webp is compatible with all known main browser, and the file size is way smaller than gif, almost half…

@PixLab - Thank you very much for replying. I have attempted your example with success; however, when I do the same with my image(s), it still has the gap. I have cropped to content and ensured that there are no transparencies at each step. The step one image is (1080 x 2160):

WWR Flag Globe 2023-1.xcf (511.4 KB)

The step two image is a saved (*.png) version of the step one image resized to 1080 x 1080.

WWR Flag Globe 2023-2.xcf (412.8 KB)

I then open the step two image and save as a step three image, in which I apply the Spinning Globe animation:

WWR Flag Globe 2023-3.xcf (8.7 MB)

The resulting globe has the gap (see frames 15 through 34). The gap appears to be between the left and right edges of the source image for some reason.

What might I be doing wrong here?

@PixLab - Well. It seems that saving each step to *.png and using those images in subsequent steps might have been the problem. I just attempted the same process but saved instead to *.jpg, and there is no longer a gap.

Just Remove the Alpha Channel on this one above that I quoted (just before doing the animation Spinning Globe)
To remove the Alpha channel right click in the layer stack, a context menu opens “Remove Alpha Channel” or go to “Layer > Transparency > Remove Alpha Channel”,

you have semi-transparent edges, not really visible, but transparency is exacerbated with the Spinning filter, removing alpha solve the problem
Or just put a gray layer underneath and merge them, then do the spinning globe

result >
Untitled.xcf (2.9 MB)

1 Like