Anyone see this: Black rectangles along darkroom image view edges

A couple of weeks ago I reported issue #8755 on GitHub, where a series of rectangles appear along the left and top display edges. The folks investigating the issue have tried to replicate the issue without success, so before we close it out, I wanted to check with the community to see if anyone has seen this.

I first saw this with DT 3.5.0+1620~g47fbd509a on my Windows 10 machine, and its occurred ever since. The anomaly may appear as black rectangles:

_MG_6262.CR2 (27.8 MB)
_MG_6262_01.CR2.xmp (7.4 KB)
Creative Commons License
This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Or as colors:

_MG_1728.CR2 (25.5 MB)
_MG_1728_01.CR2.xmp (13.1 KB)
Creative Commons License
This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Fortunately the edge anomaly doesn’t export with the image. It’s limited to editing.

Investigation has pretty much ruled out demosaicing, and there’s some consideration that it could have to do with some issues around with NaN generated in some modules, or it could simply be an issue unique to my set up.

If any one else has seen this and can provide additional clues, then please provide feedback here or on the GitHub site. Otherwise, we’ll close out the issue until more is learned.


I get something like that with photos shot with my 45mm Olympus lens, but I think it may be a lens fun issue. Doesn’t occur on any other focal length. I’m running dt on Manjato Linux

1 Like

Is it possible to share an affected RAW + XMP? Do you see this on completely unedited photo’s as well? Your Dropbox link on GitHub requires me to ask for permission, which is not very convenient.

1 Like

Sure thing. I’ve add the raw and XMP files, along with a Creative Commons license for good measure.

I see the same from time to time I just cant remember what sequence or module it might be. Mine are yellow though not black but the pattern is like yours the string of small rectangles at the edge. It might be related to zooming but I also think it goes away as well??

The only things that affect it are either zooming or changing demosiaic settings (although de mosaic was ruled out). I’ve seen the anomaly when I’ve opened a file with only the minimum modules - Filmic, Color Calibration, exposure all off and OpenCL deactivated.

Debug logs show nothing awry, so we don’t have any clues to work with, so that’s why I’m being this up with the forum.

I think always on the left side of the screen correct??

I have seen it along the top starting from the upper left, posted screenshots in the original bug. Have not seen it recently though.

It’s on the left side and the top. Never on the right or the bottom. Sometimes the blocks are black, other times they’re bright blue, green or yellow

It may also be worth mentioning that I hadn’t seen this behavior with Ver 3.4. It only started cropping up around 3.5+1600.

I’ve reported something similar, though for me it’s always colours and it’s triggered by lens correction:

@kofa There’s been a number of similar issues reported, but they all seem to be for different reasons. FWIW, I just tried to recreate your issue with on my Windows machine and found no error. Go figure.

@Dave22152 I just imported your images into my current darktable installation (ubuntu 20.04, darktable 3.5.0+2438~g941122872, Nvidia Quadro M1200 and nvidia drivers 460.80). Neither with opencl enabled nor with opencl disabled I can reproduce the issue on my side. Both images are looking fine and do not show any black or colored rectangles …

1 Like

Same here (Ubuntu 20.04, Nvidia GeForce RTX 2060, Nvidia driver 460.80). Not able to reproduce with your images and xmps, neither with opencl enabled nor disabled.

1 Like

So, are these mandelbugs or higgs-bugsons?

Well, probably an issue related to Windows / Compiler / Optimization settings / other (shared) libraries / … There are so many possibilities. We need to identify some common components when those issues are popping up.

I saw the exact same issue on Arch Linux, so it’s not Windows specific. I’m not sure about the version of the compiler or libraries since the system has been updated since last seeing the problem on Apr 24.

I had issues with black squares all over the picture some days ago. This was related to negative RGB values (Black squares / rectangles while editing an image · Issue #9022 · darktable-org/darktable · GitHub) and it’s fixed now. Probably the issues showing up here have a similar reason, e.g. NaN or negative values … especially because it shows up on the left side, i.e. beginning of calculation for a line …

This acts more like a Heisenbug

That was my hope in bringing this forward. I’d be interested in any suggestions on how to investigate further, otherwise it’s just something to live with.