Are Wavelets working as designed?

I can view levels 1–6 by setting the background to black or grey, select process one level and then select the level. However for levels 7 and higher all I get is the background. Is this WAD or should I file a bug report. Version 5.8-2482.

Could you provide a sample image to which this happens and a pp3?

See files at https://filebin.net/kb9w7z2rwroybrxa
Thanks

The file is unavaible

But I try on two others files, all seems to work well in your conditions

Wavelet levels = 9
one level
level 7, all directions
contrast enable with noting

jacques

I have just checked. They are there now and I have downloaded them to check that they can be downloaded.

What did you have for the background. If I have residual image chosen as the background I get that as an image but no detail for level 7. It is only if you have a grey or black background that you see just the details (for whatever level you choose).

This is what I get at level 6

and this is what I get at level 7 and above.

Wavelet level preview somehow depends on preview size iirc. You need at least 2^level (or maybe 2^(level+1) minimum preview size to see the effect.

@jdc Jacques, is that correct?

@RichardRegal @heckflosse

I have found why ! but I am not sure we can solve

One parameter to take into account is “denoise”

Denoise limits the number of levels for luminance to 6 and for chrominance to 7 (denoise consumes a big lot of memory…)

So if denoise is “enable” all levels greater than 6 are inactive. However if you want to see the 7th level with “denoise enabled”, one of the two “fine chroma or coarse chroma” sliders must be greater than zero.

Perhaps there is a way to solve ??

jacques

@jdc Jacques, I more thought of this stuff, though not sure about

    // adap maximum level wavelet to size of crop
    if (minwin * skip < 1024) {
        maxlevelcrop = 9;    //sampling wavelet 512
    }

    if (minwin * skip < 512) {
        maxlevelcrop = 8;    //sampling wavelet 256
    }

    if (minwin * skip < 256) {
        maxlevelcrop = 7;    //sampling 128
    }

    if (minwin * skip < 128) {
        maxlevelcrop = 6;
    }

@heckflosse

There is the 2, but (at least for my case , where my preview is large enough) I have tested with denoise : try enable / disable denoise, and try for level 7 with slider chroma :slight_smile:

But, should we look for a solution? or just put it in the documentation

I tend rather to documentation

jacques

:+1:

I suggest adding an unobtrusive notice to indicate this in-app to avoid confusion, pointing to the docs.

I think it needs to be fixed. If denoise is active then levels 7 and above simply do not work at all. I am not sure a simple not in the on-line documentation will suffice. Is it possible to put something in the wavelet levels selector or else somehow to toggle the sliders for levels 7 and above if denoise is selected?

I would be disappointed to lose the frequency based denoise if I want to keep the shape enhancing abilities of the higher levels.

Should I file a bug report to formalize this discussion?

2 Likes

Yes, please!

Done: https://github.com/Beep6581/RawTherapee/issues/5938.

There is a further problem. If I have selected 9 levels and denoise then the residual image adjustments work only on the residual after the 10th level even though contrast adjustments work only on levels 1-6. If I have selected 6 levels then the residual image adjustments work on the residual after the 6th level.

I change the GUI (see issue above), to disable Denoise in some cases

jacques

Hi @jdc,
with developement version 5.8-2530-g5fd640f97 Commit: 5fd640f97 if I open a detail window at last an more 800% and move the detail on the image with Wavelets and Denoise and refine enabled I have strange colored halos in te datail windows and 98% of the times after RT crashes into Segmentation fault.

When you have time…could you investigate , thanks :slightly_smiling_face:

@dafrasaga

I tried with various files…nothings happens…
Can you provided a raw and pp3

Thank you

Jacques

Can you try with latest version please? @jdc fixed a crash today. Maybe it’s the one you get…

@dafrasaga

I think I have found the bug…In some cases, when windows is too small, with denoise enable I think wavelet works bad

I try another time, and I will push a commit

I tried with dev into the git and it behaves the same…
OK… what I do:
I,

  1. open this _DSC7811.NEF (25.1 MB) image
  2. set the neutral profile
  3. open a detail window
  4. zoom it to 800
  5. enable wavelet module
  6. enable Denoise and refine submodule
  7. slide refine up ( 43)
  8. move the detail window on the image
  9. RT crashes