Artistic filters via command line gmic

Is there any way to import and activate the full set of users-contributed filters into command line gmic (which is being used only through command line).
I am particularly interested in cl_comic, fx_dreamsmooth, fx_posterize, fx_paint_with_brush, fx_illustration_look, and fx_graphic_novelfxl

Yes, gmic update once and they should be available.

Thanks, but…
While this is apparently the case for some filters, most of the above mentioned filters that I need from the ‘Artistic’ set don’t seam to be available in the CLI version even after gmic update:

[gmic]-1./ *** Error *** Unknown command or filename ‘fx_graphic_novelfxl’.

For example, Bokeh filter is available, but Comicbook, or GraphicNovel aren’t.

So maybe your version of gmic (CLI) is older than the one from your G’MIC-Qt plug-in ?
Both are using the same command update file, so if you have filter updates available for G’MIC-Qt, they should be available for gmic too.

gmic -version

says ?

It said 2.9.3 (default in ubuntu apt repository).

I downloaded the latest version of the package from gmic website and now have version 3.2.4

However, gmic update hangs for 10 minutes and then says “Killed”. Tried as root with the same result.

gmic update
[gmic]-0./ Start G’MIC interpreter.
[gmic]-0./ Update command definition file ‘/home/ubuntu/.config/gmic/update324.gmic’ from the G’MIC server. Killed

Killed is a cryptic message issued by the Linux kernel when the only way to free a scarce resource, such as system memory, is to pick a resource pig process and kill it. G’MIC’s update is a straightforward fetch of a text file from a remote location and may require 10-20 MB for about a minute. So — not sure what is going on here. dmesg -T| egrep -i -B100 'killed process' may turn up some useful diagnostic.

For an unknown reason, gmic does not succeed in downloading the filter update file.
In that case, get it from there : and copy/paste it into your G’MIC resources folder ($HOME/.config/gmic/ for Ubuntu), and rename it to update324.gmic.
This is how you can “manually” update your filters.

Thank you David, this worked and the filters are already available.
@grosgood , the process still exists with ‘killed’ report and dmesg -T| egrep -i -B100 'killed process shows:

[Mon May 8 16:14:45 2023] oom-kill:constraint=CONSTRAINT_NONE,nodemask=(null),cpuset=user.slice,mems_allowed=0,global_oom,task_memcg=/user.slice/user-1000.slice/session-5.scope,task=gmic,pid=3759,uid=0
[Mon May 8 16:14:45 2023] Out of memory: Killed process 3759 (gmic) total-vm:487332kB, anon-rss:366248kB, file-rss:2248kB, shmem-rss:0kB, UID:0 pgtables:852kB oom_score_adj:0

Which I interpret as needing more RAM in order to apply these gmic filters.