Automatic lens detection seems broken in RT5.8 (February 4 version)...

Hi there,

I just installed the 5.8 (February 4 version) on Windows and Linux.

On both systems rawtherapee detects my Sony ILCE 6400 fine but not the lenses: E 35mm f/1.8 OSS and E PZ 16-50mm f/3.5-5.6 OSS. I can manually select these lenses in the lens profile menu of Rawtherapee just fine and than they will work just fine too so they are installed. They just do not get automatically detected…

Greetings,
-M-

Same here for Nikon Z6 (detected) and 24-70 F4 S - not detected, but listed.

BTW I think there is another thread about this problem.

Probably related:

Later today I will try to figure out if that is due to packaging or some issue in the RT code…

EDIT: meanwhile could you try the most recent appimage from the dev branch?

Just checked the latest nighty build but same problem. The info box (i) says for example: “SONY ILCE-6400 + Unknown (35mm f/1.8)”. In this case it was the Sony E 35mm f/1.8 OSS.
If you need me to sent a sample image let me know…

-M-

Sony E…

https://raw.pixls.us/#repo is in need of a full set of RAWs for your camera; maybe you could update it with shots taken on your lenses? :beer:

1 Like

I tried to upload 2 files using the web interface here: https://raw.pixls.us/#repo

After clicking on upload a few times it says: “The file either already exists…”

I can however not see them being uploaded…

-M-

After clicking on upload a few times

That’s one way to get it to not work. Maybe try with a different filename. And just one click. Depending on the network bandwidth it might take a while…

I tried it again this time in firefox. It showwd that it was a sony ILCE-6400 file. I filled in an extra comment field. Than it said “Thank you for your submission!” but i dont see anything showed up in here: https://raw.pixls.us/data/Sony/ILCE-6400/

-M-

Maybe it’s in a queue? @patdavid Pat would tend to know!

The file must be checked and approved by either @LebedevRI or @andabata. Its a curated repository :slight_smile:

Ok :wink: we’ll see them lator…
-M-

Thank you for bringing this up to my attention.
Now that i double-check with https://www.sony.com/electronics/interchangeable-lens-cameras/ilce-6400/specifications, it seems that camera can’t actually produce uncompressed raws, so i suppose we have full set, i will adjust comments there. All the new uploads are 14bit, so i don’t believe it would be good to degrade the completeness of the set…

3 Likes

@MrDeluxe @tankist02 @ff2000 @HIRAM sorry, I am a bit lost here… is this a real issue with the automated packages or it is just due to missing support in RT?

Just to understand if some action is required from my side…

Did some testing… Like i mentioned RT does not detect my standard sony lenses on my a6400. It however does detect my standard lenses on some Canons i own…

So i guess it is specific to sony lenses and that RT does detect other lenses so it might not be a build issue.

In the meantime DarkTable detects the sony lenses just fine…

-M-

That could be due to a different naming between Rawtherapee and lensfun.
@MrDeluxe

What are:

  • the exact names of the lenses displayed by rawtherapee in the editor window
  • the exact names of those same lenses inside lensfun (the name you choose manually )

The name in the editor is: “Unknown (35mm f/1.8)”
The name i pick in lensfun is: “Sony E 35mm f/1.8 OSS”

-M-

So it is a bad decoding of the lens name in rawtherapee.

ping @heckflosse @Morgan_Hardwood

Did you clear the cache? The lensname is written into the cache. If it was written as Unknown, a nightly build will use that even if the lens is supported meanwhile.

Although i failed to upload my files, the files found in https://raw.pixls.us/data/Sony/ILCE-6400/ have the same issue.

How do i clear the cache on mac or linux?

-M-