Bug when running version 2.5

571 / 5 000

Résultats de traduction


I’m tinkering on W10 64 fam, RAM 24Go, I was on version 2.3.15 which has just announced that the update to 2.5 is available. I install on the existing version, Natron launches and closes as soon as the work screen is displayed with its various windows. No error message. I decompress again, I launch the setup and same problem. I uninstall 2.5 and reinstall 2.315, it works. I uninstall 2.3.15, I re-download 2.5, I install and still the same crash. I reinstalled 2.3.15 which seems to work perfectly. Have a good day.

1 Like


  • Have you tried v2.4.4?
  • Do you have a AMD graphics card?
  • Do you use Python scripts/plugins/addons?
  • Do you have third-party openfx plugins?

I’ve been using Natron as a supplement to ShotCut for a few months now and have upgraded each time without issue.
I have an Intel(R) Core™ i5-6300HQ CPU @ 2.30GHz and a dedicated Nvidia GTX950M video card, so on a laptop.
I didn’t see the 2.44 pass and was surprised to switch from a 2.3x version to an e 2.5.
And I haven’t seen a 2.44 in the latest versions
No plug-ins.

Please try version 2.4.4 (you don’t need to install it, just run bin/Natron.exe from the folder).

je n’ai pas tout testé mais pas de problème apparent :slight_smile:

1 Like

I also experienced the same phenomenon. Later, I found that 2.4.4 was OK. However, the 2.5 version of python 3. x had a flash back. The 2.4.4 version of python 2. x had no problem. Maybe there was a compatibility exception after upgrading the python 3 version. I hope the authorities can fix this big bug. Amitabha.

I need more information, I can’t replicate any of the reported issues for v2.5.

I thought I reported it for version 2.5, it seems to me that I had a similar problem with a version of a raw processing software which closed as soon as launched without message, the problem came from my user having an accented letter like here…

I have the same problem with 2.5. Natron 2.4.4 works fine.

Same here the version 2.5 when I open Natron, it crashes as soon to close suddenly. No error message. @rodlie maybe you need to test another computer and debug it as well, right ?

And my Natron 2.4.3 work great here no problem when i come back it.

Apart from 2.5, I did not find a version between 2.3.15 and 2.5 on the Natron site !

Here is this link : Natron 2.4.4

Merci beaucoup :smiley:

Sorry for the late reply.

I updated the Windows build with a possible fix.

SHA256 checksum: caed0b649ff2515b963f0b4fc009eb451a41d8ba3d6e5d4260253dd9e104c517

A priori you have corrected the bug, Natron 2.5 no longer crashes at startup, I have not tested the modules.
Thank you for your support.

@rodlie someone in the discord server is also having a similar issue:
They’re experiencing issues with both 2.5.0 & 2.4.4

Then it’s a (AMD) GPU driver issue, can’t do anything about it (downgrade the driver until it works). GPU issues might improve when we move to Qt5.

1 Like

They haven’t said which GPU they have. I’ll wait for them to respond to current suggestions to ask about the GPU.