Building Filmulator

I don’t think it is packaged, but it is not hard to build, even I did it!

Got stuck right here. I clicked on here. Clicked download. Clicked the download. Ubuntu said I didn’t have anything to open a .run file.



Qt from ubuntu 16.04 repos should be fine.

When I search Qt in the software center, it says no application found.

This worked for me on Ubuntu Mate 16.04:

sudo apt install libtiff5-dev libgomp1 libexiv2-dev libraw-bin libraw-dev libjpeg-turbo8-dev

sudo apt install qt5-default qtcreator qtcreator-data cmake qtdeclarative5-dev qml-module-qtquick-extras qml-module-qtquick-dialogs qml-module-qtqml-models2 qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings

git clone

Open the file, then click the green arrow button.

Ok, I got it to work and I love it. I think you (@CarVac) have the basis for a Lightroom competitor here.

This picture of my daughter and a horse has been difficult for me to process for quite a while. It’s the top left corner, it’s completely blown out. I’ve tried RawTherapee, Photivo, Darktable, Photoflow etc. They all work, but it’s a constant fight over light and dark global adjustments. With Lightroom, it’s pull down the Highlight slider - that’s it. Then I use your software. It’s pull down the Highlight slider - that’s it. You can also pull up shadows like Lightroom. My problems are the speed, it is a little slow. And, I wasn’t sure what was saving. I also had some color problems with Photivo. And, somebody really needs to package it. But this is it. This is what I’ve been looking for in a Lightroom equivalent009.CR2 (21.0 MB)

1 Like

Glad you got it working. It was also not fast for me, but I think that’s because it is doing tone mapping every time you change something. Hopefully @CarVac will come back soon and tell us what is what!

could you share your raw file. i wanna try some quick adjustment in other software and see how it compares

I’ve prepared package for Ubuntu 16.04 (Mint 18.xx) - you can find it in PPA Highly Explosive:

sudo add-apt-repository ppa:dhor/myway
sudo apt-get update
sudo apt-get install filmulator

Unfortunately, it’s only for Linux 64bit. Package for 16.10 is on the way.

I’m not sure about dependencies - in my case I was able to install Filmulator from given PPA without any problems. The only issue is with entry in menu (Mint 18.1) - can’t see any (there’s .desktop file in proper place). To solve this I run:

cd /usr/lib/filmulator-gui && /usr/lib/filmulator-gui/filmulator-gui


I’m glad to hear somebody likes it. Lovely photo, by the way.

@Dariusz_Duma: Thanks for packaging it. As for menu stuff, I still haven’t figured out how to get the .desktop file to install and work properly. If anyone has any tips, feel free to advise…

1 Like

CA Correction and Highlight Recovery changes redo the entire pipeline.
Everything else above the second mini-histogram is about equivalent speed, they all redo the Filmulation tone mapping and the post-Filmulation tone curve.
Everything below the second mini-histogram is fast, they don’t need to redo the tone mapping.

With practice, you can make adjustments before the image has finished processing. I’ll wait for the first mini-histogram to update, and then tweak settings based on experience and what that histogram shows (mostly Highlight Recovery, Exposure Compensation, Drama, White Clipping Point, and Shadow Brightness).

I attached the file. Look for the link at the end of my post.:slight_smile:

Awesome, thanks for the clarification.

It seems you have ~/.config/Unknown Organization/filmulator-gui.conf and ~/.config/Filmulator.conf (this is using the built from source version).

The menu item from @Dariusz_Duma PPA works for me on Ubuntu MATE 16.04.

I’m not sure where the Unknown Organization one comes from. It seems some of the components (file dialog) end up making that one. The ~/.config/Filmulator.conf one is the one I created. I’ll look into it.

I’ve made some changes to the config file locations; the Unknown Organization one didn’t end up going into the same one for some reason but instead a generic QtProject.conf file in ~/.config/. The Filmulator specific configuration file is now in ~/.config/Filmulator/Filmulator.conf.


Thanks for the build. I wonder why starting it as you mention works while calling filmulator from another directory with full path gives

dbSetup old version: 8
QQmlApplicationEngine failed to load component
file:///<actual directory>/qml/filmulator-gui/main.qml:-1 File not found

Error: your root item has to be a Window
QThread: Destroyed while thread is still running

Has to be some absolute vs relative path stuff.

I hope to try Filmulator someday. Building software is not meant for me so I applaud everyone’s efforts. Not having room for Linux on my Windows machine might make the wait a lot longer :laughing:.

One click conversion in a preset i made in Lightzone with a quick zone mapping. all in all less then one minute of pp. Anyway, couldnt get much out of highlight reconstruction because LZ isnt very strong in that department, tho i like LZ colors more. Filmulator’s are kinda palish. Could you add some warmth to te pic and repost? :slight_smile:

The Filmulator executable needs to know where the QML (user interface) files are, they’re interpreted. So you need to cd to the directory with the QML files before running the executable.