Call for testing: experimental AppImage package for LuminanceHDR

I have just finished preparing a first experimental AppImage package for LuminanceHDR, that can be downloaded from here.

In order to validate the package, it is important to test it on as many Linux distributions as possible.
Running the appimage is easy:

  • download the package
  • make the downloaded file executable with chmod +x
  • run the file

Please give feedback wether the package runs on your system or not, specifying your Linux distribution/version and, in case of issues, please also provide the full terminal output.

Thanks in advance for checking!


Tested in Sabayon. It took about 30 seconds to start the first time, then it ran fine. HDR file created, tonemapped and saved without issues.

1 Like

Loads ok on Ubuntu 16.04.
However I couldn’t load files from my data partition (it was mounted). Clicking “computer” gave just one item, “/”, and double-clicking that gave the folders from bin to var, but no sign of any volumes.

1 Like

Works well on Ubuntu 17:10. I tested loading raw files and tone mapping and saving and loading .exr files.

I had no problems navigating to different disk drives or an sdcard.

1 Like

Starts on Debian 9 without any issues. I only tried one HDR export from 3 TIFFs, because I have no experience with LHDR.
UI language remains in English no matter what is set in the preferences. That’s all.

log.txt (8.8 KB)

1 Like

I also observed the same when testing the package. No idea what it is doing the first time…

Did you notice any suspicious terminal message?

I will try to find out what is wrong with the internationalization… probably some files missing in the AppImage bundle.

No, this is how Terminal finishes up after loading L.HDR - => /lib/x86_64-linux-gnu/ (0x00007f9323e92000) => /lib/x86_64-linux-gnu/ (0x00007f9323c7e000)

/luminance-hdr “”

Then with “New HDR image” and trying (but failing) to find a volume, there are no further messages.

Mounted volume details

Running Linux Mint 18.3 Cinnamon. First Time using LuminanceHDR. I used it on a single jpg image I shot. It performed better than expected. Thanks for this…


@Carmelo_DrRaw Hi, I tried the latest LHDR appimage (luminance-hdr-git-20181016_1157.glibc2.15-x86_64) but it core dumped. Here’s the console output:

DIR: /tmp/.mount_xpvBa0
System stdc++ library: "/usr/lib/"
System stdc++ library version: "3.4.25"
Bundled stdc++ library version: "3.4.22"
Newest stdc++ library version: "3.4.25"
Using system stdc++ library
GDK_PIXBUF_MODULEDIR: /tmp/.mount_xpvBa0/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders
GDK_PIXBUF_MODULE_FILE: /tmp/.mount_xpvBa0/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache
cat: /tmp/.mount_xpvBa0/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache: No such file or directory
Input parameters: ""

Input File: (0x00007ffe4baf3000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdec157d000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdec133a000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdec111c000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdec0e6d000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdec0c67000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdec0a61000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdec07ec000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdec050e000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdec0109000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdebff02000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdebfaa2000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdebf856000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdebf407000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdebf1b2000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdebef5d000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdebed37000) => /usr/lib/ (0x00007fdebead8000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdebe86a000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdebe652000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdebe44b000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdebe247000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdebe036000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdebde34000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdebddf8000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdebddb1000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdebdd72000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb8136000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb8116000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb80d6000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb8067000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb7c18000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb7804000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb7687000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb703c000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb7034000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb6ae3000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb65c1000) => /usr/lib/ (0x00007fdeb6432000) => /usr/lib/ (0x00007fdeb62ad000) => /usr/lib/ (0x00007fdeb627d000) => /usr/lib/ (0x00007fdeb6263000) => /usr/lib/ (0x00007fdeb6242000) => /usr/lib/ (0x00007fdeb607c000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb5e5a000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb5c4c000) => /usr/lib/ (0x00007fdeb5c10000) => /usr/lib/ (0x00007fdeb5c06000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb5bf1000) => /usr/lib/ (0x00007fdeb5bec000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb58e4000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb56a8000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb5405000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb50c5000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb4e98000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb4c6c000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb4a2f000) => /usr/lib/ (0x00007fdeb48f0000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb46e0000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb44cc000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb42c2000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb40bc000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb3eb2000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb3cae000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb3aab000) => /usr/lib/ (0x00007fdeb37c9000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb3581000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb337e000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb3178000) => /usr/lib/ (0x00007fdeb3125000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb2dbe000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb2b7f000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb2979000)
	/lib64/ => /usr/lib64/ (0x00007fdec1937000) => /usr/lib/ (0x00007fdeb28e6000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb24df000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb2164000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb1f26000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb1d21000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb1b1d000) => /usr/lib/ (0x00007fdeb1af3000) => /usr/lib/ (0x00007fdeb1a65000) => /usr/lib/ (0x00007fdeb1a32000) => /usr/lib/ (0x00007fdeb1976000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeb0109000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeaff05000) => /tmp/.mount_xpvBa0/usr/lib/ (0x00007fdeafcfd000) => /usr/lib/ (0x00007fdeafcde000) => /usr/lib/ (0x00007fdeaf9c2000) => /usr/lib/ (0x00007fdeaf7a2000)

/luminance-hdr ""
Could not initialize GLX
/tmp/.mount_xpvBa0/AppRun: line 119: 21239 Aborted                 (core dumped) bin/luminance-hdr "$@"

My machine runs on Manjaro.