Call for testing: HDRMerge AppImage

appimage

(Carmelo Dr Raw) #1

I have just finished setting up the Travis AppImage scripts for HDRMerge.

I would greatly appreciate if you could give me some feedback regarding wether the HDRMerge AppImage works on your preferred linux distribution, and if you could provide me the full terminal output in case it fails. Positive feedback is also needed in order to see which linux versions are OK, as I only tested Ubuntu 17.04 so far.

The AppImage packages can be downloaded from here.

Once the package is verified, I will set things up such that a new package will be built each time there is a commit pushed to github.

Thanks!


(Morgan Hardwood) #2

@Carmelo_DrRaw well done, runs fine in Sabayon.


(Cyhex) #3

works fine on Ubuntu 17.10


(Brian Innes) #4

Works fine in Ubuntu Mate 18.04


(Eduardo Bohoyo) #5

Wokrs fine in Manjaro 17.1.8 with plasma


#6

Still looks fine on Ubuntu Studio 18.04.


#7

I tried it on my Ubuntu subsystem (i.e., Ubuntu on win10). Output:

fuse: device not found, try 'modprobe fuse' first
Could not mount AppImage
Please see https://github.com/probonopd/AppImageKit/wiki/FUSE
modprobe: ERROR: ../libkmod/libkmod.c:586 kmod_search_moddep() could not open moddep file '/lib/modules/4.4.0-43-Microsoft/modules.dep.bin'
modprobe: FATAL: Module fuse not found in directory /lib/modules/4.4.0-43-Microsoft

I also tried compiling HDRMerge but could not run the GUI. I don’t think the subsystem supports GUI.

Anyway, I did all this because I could not find @gaaned92’s Windows build. It didn’t work for me before but I want to try it again.


(Carmelo Dr Raw) #8

@afre You need to install the FUSE subsystem and drivers… but I do not know if that’s possible in “Ubuntu on win10”. For example, FUSE is not available in Docker containers.

A simple workaround is to extract the contents of the AppImage and run the launcher script directly:

  • install the bsdtar package
  • extract the appimage:
mkdir -p HDRMerge.AppDir && cd HDRMerge.AppDir
bsdtar xfp hdrmerge_appimage_you_downloaded
./AppRun

More details here.

Hope this helps!


#9

I mistakenly deleted the build.

HDRmerge_master_continuous-21-g085e8e3_release_64.zip

uploaded at
https://keybase.pub/gaaned92/LHDR64/


#10

@Carmelo_DrRaw Thanks for your suggestion.

@gaaned92 At first, I had trouble loading the raws like before; but after several more tries, it worked!


(Carmelo Dr Raw) #11

Dear HDRMerge enthusiasts! I have a new version of the AppImage package for testing.

Compared to the ones provided until now, this one is being build under CentOS7 and not Ubuntu 14.04.

The advantage is a better compatibility with older systems (CentOS 7 is based on glibc 2.17), but also an easier set-up of the build environment, since all dependencies apart from LibRAW are available as standard RPM packages.

This has also some positive security aspects: the packages are freshly updated and installed each time a new AppImage is build, so new AppImages are guaranteed to ship the most up-to-date CentOS 7 libraries.

I would appreciate if you could test the new package and give me feedback, both positive and negative. The package is available from here: https://transfer.sh/h80ne/hdrmerge-git-20180922-x86_64.AppImage

Thanks!


(Mica) #12

Does HDRMerge have an icon? If not we need to make one!


#13

Link to images: https://github.com/jcelaya/hdrmerge/tree/master/data/images