Can someone running a version newer than 4.3 +65 or so try dehaze... seems broken (Solved for now)

I am running WIn11 and have noticed that my machine at home running DT 4.3 +104 has a broken dehaze module…

At work 4.3 +65 worked fine…

I only noticed as it was reported by someone on the FB page so I went looking…

Anyone else see this??

4.3.0+245 on Lunix “haze removal” module works fine.
“dehaze” on diffuse or sharpen seems ok, also.

Okay several users on FB reported what I saw I will update my build and see if it goes away…

Edit Just closed DT and reopened to confirm and now its it working… very funny. This is the second weird issue I have had after having DT open for some time…in any case its working and i will try to make not of it when and if it shows up again… Sorry for the noise…

Is the problem noticeable after doing one full size export ?

It was in my case resolved by a shutdown and restart but if it shows up again I will try to figure it out…a second one that has happened occasionally and it was also reported by someone is that applying astrodenoise crashes DT. I’ll have to start running in debug so if it happens I can perhaps capture more information…

Still broken for me, after app and system restarts.

As stated (somewhere?) before lowering the strength below zero does wash it out, but raising it above zero (and / or changing the distance slider) makes no change to the preview at all. However, changes are shown in the thumbnail in lighttable.

Here’s an interesting sequence:

  1. Open darktable and load the image in darktoom
  2. Make haze removal edits, changes per above not seen in the preview nor in the filmstrip thumbnail. Leave both sliders at max.
  3. Switch to lighttable and its thumbnail shows the edit.
  4. Switch back to darkroom and the preview doesn’t show the edit, nor does the filmstrip thumbnail.

… but …

  1. Click an adjacent image in the darkroom filmstrip to load it and the dehazed thumbnail shows the edit
  2. Click the dehazed image in the filmstrip to reload the hazy image and both the thumbnail and preview don’t show the edit.

Earlier, step #6 would indeed cause the edit to show on the preview, until it was zoomed, etc., Then it reverted to the unedited view. But now I can’t replicate that, it just stays unedited-looking.

darktable 4.3.0+114~ga5c82f32b on Windows 11

Alright, #6 just happened again as I said it had previously (dehaze is ridiculously overdone for clarity):

  1. Image after edit, but with no results on preview nor filmstrip thumbnail:

  1. Select adjacent image in filmstrip, then the preview of the hazy image shows the edit:

  1. Re-select the de-hazed image and this time the preview – but not the thumbnail – shows the edit:

  1. Zoom in and back out, then the edit’s gone:

  1. But even still the edit shows in the lighttable:


One time (only) when I switched from lighttable back to darkroom did the preview show the edit, but zooming reverted it as above. At no point did any exported image show the edits, whether exported from darkroom nor lighttable.

My version of DT often crashes when I apply astrodenoise or more likely when I move the slider in the module. I presume the module is resource hungry and my laptop is a few years old now, so it may be resource deficient.

My PC is not … 12 gen intel with 32 gb ddr5 NV drives and 3060Ti GPU and it happens almost instantly on activation when it does so it is triggering something…

I tried these steps in 4.3.0~git287.8471c8b7 and I cant reproduce it. I tried with and without OpenCL.

I recall that you are on AMD card. Can you reproduce the same issue with OpenCL off?

I tried it with my previous weekly (same as above) and then with the new Jan 22 weekly (same as you), with OpenCL both on and off. No difference - Same behavior as originally reported (preview never changed with positive strength).

I tried with a default / new profile folder and for a moment it appeared to be working. But then I noticed that nothing in the preview would change as I increased strength until it got past about ~0.85 at which point it abruptly updated to that overkill strength. As I played with it after a couple more slider moves it ceased to work at all (back to originally reported behavior).

So is it AMD? Dunno, but the fact that it worked … sorta / momentarily … then didn’t seems to indicate some kind of issue anyway.