Cannot install Siril 1.2.3

I’m running Windows 11 Home and having trouble installing the newest version (1.2.3). Windows defender blocks the installation, but if I bypass that it gives the following error: Unable to execute the file in the temporary directory. Setup aborted. Error 5: Access is denied.

I tried running it as administrator too, but got the same error.

Looks like you try to run the file in a directory you haven’t the right.
It is not a Siril issue, this is a problem on your side:

I’ve tried to install it from my Downloads folder and Desktop with no success. I have installed innumerable other executables from both of these locations. I have all necessary permissions on the temp folder. Previous installation files (Siril 1.2.1 and 1.2.2) work fine in either location.

Disabling antivirus did the trick…

I am running Kaspersky and it definitely does not like this installer. It stopped the process and deleted all material from the temp directory as soon as I reactivated the antivirus.

According to Kaspersky it is behaving like Trojan.Win32.Bazon.a

Not saying that it is infected, but Kaspersky is identifying the Siril 1.2.3 installer as such.

yes for every release we have to ask antivirus companies to clear the exe and I doubt this was done for this version

It’s been a long time since that was done …