Cannot load raw from Minolta Dynax/Maxxum 5D

First, I’m very new to photo editing. I just got the Minolta Dynax/Maxxum 5D and am willing to try some raw editing with this camera. Then I found Darktable, which can edit raw files from Minolta 5D, as it says on the “supported camera” list. Once I got into the program and dropped my file, it seem to see my file, and when I went to “darkroom”, the massge pops up saying “couldn’t load the file”. I’ve tried it so many times now and still not able to load it. I hope I can get an answer.

The raw files of this camera is .MRW
My Darktable version is 4.8.0
My OS is Windows 11 Home v.22H2
Here is some of my files for you guys
Camera (23.0 MB)
(There’re only a few pics; I tried to avoid my friends’ faces.)

Sorry for if this message is hard to read, I kinda struggling with English.

Could you share one of the images so others can try opening it. In the meantime while waiting for an appropriate answer, I have found that unsupported cameras can be processed in DT or any program if they are first converted to a DNG file. Adobe provides a free DNG converter which I have used on Windows.

Also let people know which version of DT you are using. The latest version is 4.8. Your OS is probably not important but it might be worth mentioning as well.

Thank you, Terry. I edited my post

Is that the same as the one listed here are no longer supported…

I had time to look…its not… sorry

ART can manage your RAW files.
If you are Japanese, please refer my Japanese instructions of ART in following link.

I am not sure if it is possible to get this camera supported in DT, but the good news is that you can use Adobe’s DNG converter which is free and works on Windows to convert the files to a DNG so that DT and other programs can process this image as if it were a raw file. I just tested one of your images and it opened fine as a DNG in DT.

I’ve renamed the topic to make the title descriptive. has a sample for the Minolta Dynax 5D, which can be opened in dt 4.8.0.

But the samples provided by @Fried_Yakults show a different maker and model:

  • 5D sample from
    • maker: Minolta
    • model: Dynax 5D
  • samples from OP:
    • maker: KONICA MINOLTA

Those Exif items are used to determine the camera model, so it’s not surprising dt doesn’t recognise the images, and refuses to open them…

According to wikipedia, this is the Minolta Dynax 5D, rebranded for different markets. Then it should be possible to create an alias in the rawspeed camera list.
I don’t know how to do that, though.


I can confirm that my old Konica-Minolta Dynax 5D raw files open fine in DT 4.8.0. My camera was for the UK (european?) market, if that helps.

I can take a look later tonight. I will convert it to DNG in Adobe DNG Converter and check the color matrix and black/white levels, so that they are the same as the one in Rawspeed.

If they are the same, then it will be easy to add an Alias. The Maker part, Minolta Vs KONICA MINOLTA, may be an issue for an Alias though.

The file to change is cameras.xml and there is no need to recompile darktable after.

The better/more permanent fix is to open an issue on GitHub and request that support be added. Make sure to include a raw file.


And submit samples to

ColorMatrix2 is used in Rawspeed as default Color matrix. Same as with this model.


12561 -5625 162 
-7016 14543 2693 
-489 628 6558

10284 -3283 -1086 
-7957 15762 2316 
-829 882 6644

Same black level and same white level.

What I added in the file cameras.xml

No sample on RPU, no GitHub request - no support.


But, what if the camera under discussion is a Dynax 5D, sold under a different name? (cf. my previous post and the link in that)

We’d still want samples so we can see the exact metadata, but adding support would be trivial.

1 Like

MRW files have camera IDs and these files match the Maxxum 5D ID.

I successfully opened OP’s images in Darktable by editing the EXIF data using jExifToolGui. Load the files, select all, click the “Edit Data” tab, and enter “DYNAX 5D” as the camera model, then “save to selected images” (click “backup originals if required”). In Darktable I also had to reset the Black/Whitepoint on two of the images.

As i’ve said previously, there really should be a “THIS IS NOT THE PLACE TO REPORT BUGS” post pinned at the top of this category.

1 Like

Thanks to everyone who replied to this topic, such overwhelming feedback! This community is something I’ve never seen before. I tried summiting a sample like @paperdigits told me and tried using a DNG converter like @Terry told me, and it worked. I really appreciate your effort given to my topic.