Cannot Load Starnet database into iMac

Hi Siril Users, I am VERY new to this, so please forgive my ignorance ! I am running Siril Ver 1.2.0 on my macOS Sonoma ver 14.3, intel core, 128GB memory. I cannot load Starnetv2CLi, When loading starnet++, I keep on getting an error message saying “You don’t have permission to execute this file” ? I have set all permissions to “Read & Write”, but will not load any file. See attachment. Any help would be very gratefully received. Thank you. Pete (UK).

Did you tried if starnet command line works?

Thanks for your reply, again, forgive my ignorance, but it does not have an exe file as it is a Mac ? Unless there is a way to “run” any of the files a different way ?? Thanks.

Siril only executes the binary from StarNet. So as we explain in the documentation:

You can use the command line on macOS

Thanks once again, but the problem seems to be a “permissions” issue ? You mention I can use the command line on macOS to run Starnet ? Is that the same as Terminal ? Please be as simplistic as possible, as I’m not used to doing this kind of stuff ! Appreciate your help.

Did you read the documentation. It explains everything, as simplistic as possible.

YES !!! Thank you so much, that seems to have worked ! The only “problem” was that second command kicked up the following error message, see below, but it all seems to be working now, so thank you for your patience & pointing me to the right help page. I was looking for error messages within Starnet, not star removal ! Thanks - Pete (UK).

peterwilliams@Peters-New-iMac StarNetv2CLI_MacOS % xattr -r -d starnet++

xattr: [Errno 13] Permission denied: ‘starnet++’