Cannot run Rapid Photo Developer 0.9.24 from menu - Solved

I have been running RPD 0.9.9 on my Xubuntu 18.04 linux system for some years. Yesterday I decided to install 0.9.24, downloaded and ran the install,py.
When I clicked the (whisker) menu entry I got the following error message@
'Failed to execute command ‘rapid-photo-downloader %f’ (… child process … no such file)

However if I run ‘rapid-photo-downloader’ from the terminal it runs perfectly.
I’ve tried to create a new .desktop file but that files with a similar ‘failed to execute child’ message.
There have been reports of similar problems but I can’t see a solution.

The script :"

-- coding: utf-8 --

import re
import sys
from raphodo.rapid import main
if name == ‘main’:
sys.argv[0] = re.sub(r’(-script.pyw|.exe)?$’, ‘’, sys.argv[0])
is in $HOME/.local/bin which is in my $PATH

I (think) I had the same issue a couple of days ago. I ran the install script again and then it worked.

@iainrs I replicated your setup and could not reproduce the error. It worked for me. Running the script again will not hurt. Also, you may like to try to restart if you didn’t already.

Very strange !
I rebooted, uninstalled RPD,then re-downloaded and rerun
Still getting same error.
I created a bash script which worked from the terminal not from menu or panel.
Thought it must be a path problem.
Changed exec : ‘rapid-photo-downloader’ to
and it worked.
Running from a .desktop launcher does not pick up $PATH from .bashrc !
Maybe an Xfce problem ?

I very much suspect so, yes. Well-formed desktop files are meant to just work.

Thanks for reporting back with your findings.