cannot save a picture after changing

i’m using GIMP 2.10.30 ver. on Windows 11.
As far as i know, saving photo in the same file type can be in the “Export As…”
when i make a changes on a tif file and want to save it at the same file type i “Export As…”
but the changes that i made doesn’t effect.

i’ll happy to get any help.



I’ve modified the tags (RawTherapee → Gimp).
Do you get an error? Are file permissions correct?
Does the file size and/or date change? Or are you trying to create a new file? In that case, is the new file created?

If you do something very obvious, such as flipping from landscape to portrait, is that not reflected in the output file?

What do you mean by changes don’t take effect? Does your output look the same as the input? Or does it not reflect what you see in Gimp? Can you post screenshots?

Please describe what you see in detail; otherwise we’ll be unable to help.

thanks kofa,
i was made a flipping the photo.
i attached a print screen the steps i made:

first screen after i made a change:

second step and i press on “Replace”:


in the 3th print screen i press on “Export”


and thats all.

So there is no error message when you save the updated photo, but when you re-open it, the flipping is not visible? (I assume you flipped it horizontally.)

BTW, if you really want to overwrite your input, you can simply use File → Overwrite (the option above Export As… in your screenshot).

You did not answer the following:

Are file permissions correct?
Does the file size and/or date change?

after exporting the file, i’m going to the original file that i overwrite it and i saw that the changes didn’t take afect.
by the way, i tryed to make the File → Overwrite and it was the same.
and yes, the file permission is correct (i’m the owner) and the file size or date ddin’t chamged.
it very strange because in the first files on this work session i the changes was succeed.


You don’t mention which program you use to check the original. Could it be that the old version is still cached?

I use XnView and, depending on the settings, it tends to show the cached (=old) version and I have to force a refresh to see the newer version. I’ve seen this behaviour with other viewers as well.

Just my ideas about overwriting the original: Don’t. Create a separate copy you work on and only if you are 100% sure that you are done you could consider renaming it to the original name. But even in this situation I would not: Diskspace isn’t all that expensive and being able to grab the original at any point in time is worth it.

i’m using the PICASA viewer.
but it the same at the PHOTOS buid in from WINDOWS.
by the way, i paid attention that if i export it to another place and not overwrit hte file, all changes was activeted successfuly.


Do you perhaps have it open while you export?
Is there enough free disk space?
I’m with Jacques here on not overwriting images.

i have an ASUS LapTop:
Intel(R) Core™ i5-1035G1 CPU @ 1.00GHz 1.19 GHz
RAM 16Gb
287Gb free space on my SSD HD.
i tried to save on open or close folder and it was the same.
i"m sure that you can duplicate the problem if you’ll have the same Win11 + Gimp 2.10.30

@yaacovk Hello and welcome!

I have two questions:

  1. How do you get the image into The Gimp?

  2. What happens after you have clicked Export As, but
    before the Replace/Cancel dialog shows? Screen dump, please.

I am absolutely certain that your dilemma will be solved, but it might
take some time before The Proper Solution™ will pop up :slight_smile:

Have fun!
Claes in Lund, Sweden

Thank you Claes.

  1. i open the image in twq ways.
  • At the Gimp, File —> Open —> go to the tarfen folder/file
  • At the file itself, i choos with the right mous click and choos “open with”…Gimp
  1. i attached print screen above durind “Export As”… save files setps

Thank you.


Thank you.

What is a tarfen folder/file?

What puzzles me is that when I click Export As,
a dialog box pops up (before I get the warning about
same name):

Screenshot 2022-02-09 145302

I have just tested this on Win11 with the same Gimp version as you have, and it works
as expected…

Have fun!
Claes in Lund, Sweden

I ran into a similar problem, but I think I may have found a solution, at least for my case. Saving into another folder did not help. My issue was what I saw and saved looked different. I was trying to edit an icon and replace some colors. The image I started with used “Indexed” colors.

I just had to change the colors to use RGB.

Menu “Image” → “Mode” → change from “Indexed…” to “RGB”.

I think before it retained the original color pallet when saving, as the indexes weren’t updated with using things like the bucket tool. I was even seeing some pixels I had erased. It became more apparent when the Layers panel appeared to show the old colors, even though the image tab did not.

If you switch to RGB mode, the colormap is discarded. If you re-index, a new colormap is generated.

However if you load an image as a layer over a color-indexed image, the added layer keeps its colors, and the re-indexation of the top layer only occurs when you export, so you indeed see a color change at that point.