Can't move crop handles sometimes

I’ve run into some apparently odd and inconsistent behavior from the crop handles in the “crop and rotate” module. Sometimes they seem to just get “stuck” and refuse to move. Certain images seem to just never allow it, some it will work but then suddenly stop. Sometimes the corner handle that should allow changing width and height will only allow changes in one dimension. This is all using 0 rotation angle, and “freehand” aspect ratio.

It feels buggy to me, but I thought I’d check before claiming that.

I took several screen caps, this is the most succinct, but there are 3 more showing variations on the same behavior. I tried to turn off all other modules, so the pics look terrible, but I think the point remains.

The only thing I can determine may have precipitated this was changing the UI theme from “darktable” to “darktable-icons-grey”. But I tried changing it back and restarting darktable (twice, actually) which did not seem to fix it.

Your Operating System and version, darktable version and making sure you’re using the latest 3.2.1 would be helpful.

Intermittent issues are often hard to diagnose, so if you can provide any logs, that’s also useful.

Doh, sorry!

Windows 10 Home (Version 10.0.19041 Build 19041),
darktable v3.2.1

I don’t have any crash logs because it doesn’t crash. I restarted it from a console with “-d all” flag, log attached. (74.4 KB)

I have had this as well on a similar environment to the OP.
It appears to be a timing issue for me and more noticeable when there are lots of modules active.
The crop module appears to be initialising and the handles become a little temperamental until it is ready.
One way I have noticed to get over it is to click and hold the left mouse button down in the centre until the dimensions appear and then the handles seem to work as they should. If you try and move the handles before that then they just refuse to move or sometimes they do only in one direction.
Maybe Brian you could try this to see if it gets over the issue for you at least temporarily?

1 Like

Thanks for the suggestions Martin, but I think that might be a different issue that presents similarly.

I just tried your suggestions, even leaving a photo open for several minutes, and it still won’t let me crop it. I’ve also seen the crop handles work, then stop responding, then start again after resetting the module.