cant see files of submaps in browser (collections)

We are installing a new version of Darktable and it seems that there are some changes.
We have an archive of a neighborhood and we have a structure like this:
We want to click the year in ‘collections’ (we set folder in the preferences)
However, we can no longer see the files of the subfolders. Is there a possibility to activate this option. (in the past this was possible)
Thanks to help us.

Hi, and welcome to pixls!

Are you talking about this when importing files:

Make sure recursive directory is checked. As you can see (2 horizontal arrows) it sees/shows the directories inside the Stable directory.

Or are you talking about this section:


Out of the box it shows individual directories that hold images, but you can create a preference to show whole selections.

In the search field (red arrow) enter, for example, something like:


This needs to be a full path, easiest way to get a good starting point: Double click on one of the already existing entries and edit that one.

After pressing enter you should see all files in all the subdirectories inside /2014/project/. The % is a wildcard.

Use the hamburger (red circle) to access the store new preset… option. Give it a name and you’re good to go.

There are other tips & trick you might be interested in: dtdocs - collections