Can't seem to build with lua support

I’ve got a fresh install of Ubuntu 18.04 and trying to build darktable 3.0.0 from source with lua support. I used sudo apt install lua5.3 and copied the binary so it can be found in /usr/bin/lua5.3 and /usr/local/bin/lua5.3. I built from source but still get
-- Checking for one of the modules 'lua53;lua5.3;lua-5.3;lua' -- Lua support: System library for lua 5.3 not found (to use darktable's version use -DDONT_USE_INTERNAL_LUA=Off)
So I ran build with -DDONT_USE_INTERNAL_LUA=Off and still no lua. I get no complaints when running darktable -d lua so I am at a loss. I have no idea what else I could be missing.

Are you sure you don’t need the -dev version of the library?

I am not sure… but now I am. Is that mentioned some where I didn’t look?

I dunno, that’s the way Debian packages generally work: if you want to build something that uses the package as a dependency, you generally need the -dev package.

Good to know. Still new to building. Thank you!