Can't start the latest dev version of RawTherapee for Win64

I downloaded this version yesterday, April 27 - 2021 and after telling Win Defender that everything is ok, the application started fine and I could manage local adjustments.
RawTherapee_dev_5.8-2826-gca5a9a26d_20210322_win64.zip
To day the RT would not start - showed a white screen in the tip image from the task bar.
Made a new folder on the desktop with all rights - moved the zip file from Download to this new RT folder and unzipped.
When I double click the rawtherapee.exe - even as an administrator - the above happens - i.e. nothing loads.
The June 20 discussion is not helping.
Could use some help.

Mojn, Eigil,

Did you get a warning from Windows Defender?

Mvh
Claes fra Lund, Sverige

I had the same problem. Delete the options file located for example in “C:\Users\Mike\AppData\Local\RawTherapee5-dev” and it should work fine after that.

I don’t know the work around to avoid having to delete this file so, if anyone does then please let us know.

1 Like

Hej Claes,
Yes, the first start released a warning - something about - this program has no origin. I chose “more” and “run anyway”.

Hi Mike,
It still don’t work here, but thank you for the suggestion.

Have you tried turning completely off Windows Defender?

Hi XavAL,
I have now - Defender totally off makes no difference. Further RT is set as a local exception for the firewall.
I am running Opera browser - but I can’t image that as a problem, as the combination has worked fine up till now.

I didn’t mean that it was the problem, but a usual workflow I follow to find something which is causing problems is guessing what can be doing it and turn off one thing at a time.

When something changes the behavior (e.g., RT starts working again), then I note the last thing I have turned off, and start turning things on again, one at a time, just in case it’s the mix of 2 apps, daemons, …, which are causing me trouble altogether (but not alone).

Anyway, sorry it didn’t solve anything.

I know what you mean - it COULD have been the problem. All suggestions are welcome.

It could be this annoying glitch in RT.
From time to time, it may happen that in the option file/GUI section, the two parameters WindowX and
WindowYare set to something like -32768.
In that case the RT window is lost off screen.
Setting these parameters to 0 cures the problem.
Or you get back the window on screen: https://www.howtogeek.com/howto/windows/bring-misplaced-off-screen-windows-back-to-your-desktop-keyboard-trick/

1 Like

My English is not very precise, excuse me. Automatic translation. Then Original version in French.
In my case, I have been using Gaaned92’s Skylake builts for several months, which work very well.
The other builts, generic or not, had only given a white screen for several months.
I only use the zip files put in any folder on the desktop. Several can coexist.
On the other hand, I must necessarily modify the ‘options’ file.
Otherwise impossible to install because white screen!
What I do once the built Skylake is unzipped:
options> notepad> [General] > MultiUser = false

For control, I repeated today a test with ‘multiUser = true’, so the current built Skylake unmodified => White screen.
By erasing everything then putting back ‘MultiUser = false’ Rawtherapee works again!

My configuration:
Intel ® Core ™ i3-5005U CPU
2.00GHz 2.00 GHz RAM 12GB x64
W10 always updated. Windows Defender still active. Without other anti-virus.


Version originale en français:
Mon anglais étant peu précis, excusez-moi. Traduction automatique. Ensuite Version originale en français.
Dans mon cas j’utilise depuis plusieurs mois les builts Skylake de gaaned92 qui fonctionnent très bien.
Les autres builts, generic ou non ne donnaient, depuis plusieurs mois, qu’un écran blanc.
Je n’ utilise que les zip mis dans un dossier quelconque du desktop.Plusieurs peuvent coexister.
Par contre, obligatoirement, je suis obligé de modifier le fichier “options”.
Sinon impossible d’ installer car écran blanc!
Ce que je fais une fois le built Skylake dézippé:
options > notepad > [General] > MultiUser=false

Pour contrôle j’ ai refait aujourd’hui un test avec “multiUser=true”, donc le built Skylake actuel non modifié => Ecran blanc.
En effaçant tout puis en remettant “MultiUser=false” Rawtherapee refonctionne!

Ma configuration:
Intel® Core™ i3-5005U CPU @ 2.00GHz 2.00 GHz RAM 12Go x64
W10 toujours mis à jour. Windows Defender toujours actif. Sans autres anti-Virus.

3 Likes

Hi Alain,
That did the trick - MultiUser=false in the options file.
Thank you very much.

Well, that probably explains why I have to delete the options file every time I use one of @gaaned92 Skylake dev builds as well as the automated GitHuub builds. Hopefully @Cempoub fix will continue to work. Thanks!

Hi Mike,
But with me deletion of the entire options file didn’t work. Keeping the file and changing the MultiUser flag to false worked.
Interesting how things work differently from one environment to the next.

2 Likes

You see Eigil, I told you the forum would get you sorted quickly :+1:

1 Like

Halløjsa, Eigil!

Interesting how things work differently from one environment to the next.

Absolutely true – because I had MultiUser set to true, and it still worked…

Mvh
Claes fra Lund, Sverige

And it did.
Thank you, Andy.

Goddag Claes,
Nice to meet a fellow Scandinavian (a Swede with skills in Danish - or a Dane with a Swedish name?).
I have lived for four years near Ystad in Scania up till 2016, and though I origin from Zealand, I have settled on Als close to the German border.

I will reply in a private message, in order to
try keeping the forum pure :slight_smile:

I agree, Claes.
eigil.skovgaard(at)gmail.com is available.