Can't update filters


(hover) #1

When I click on update, it says it can not download update242.
I have latest version of GMIC and GIMP.


(Mica) #2

Can you click the refresh button a couple of times?

What OS are you using?


(hover) #3

Win10, nothing happens if I refresh button a couple of times.
Capture


(G'MIC staff) #4

This is an issue that seems to be recurrent, and we don’t have any clues why it happens.
We believe that the filter update works for most people (at least we hope so!).

In our experiments, we never experienced this issue before, whether it’s on Linux or on Windows.
We use the Qt API to access to the update file over the network, so no exotic ways to do it.
Could it be you have some custom firewall rules ? Or a specific antivirus which may think the plug-in is trying to do something nasty ?


(hover) #5

I disabled everything but still can’t download it.

Is it possible to download full GMIC with latest filters?


#6

I have also had the problem off and on and at least the last two versions. The easiest way is to download the file from the website.


(hover) #7

Where is the link of full version?


(G'MIC staff) #8

It is always possible to perform the update “manually”, by following these simple steps:

  1. Download the latest update file, for you, it is probably : https://gmic.eu/update242.gmic
  2. Move this file in the gmic/ configuration folder, that is %APPDATA\gmic\ on Windows, or $HOME/.config/gmic/ on Linux.
  3. Launch the plug-in, and see if you have all the filters (currently 530+).

(hover) #9

Thank you that worked!!!


#10

For future versions, just substitute the version number in the link. http://gmic.eu/update242.gmic would be http://gmic.eu/update243.gmic for the next release. Assuming the new version is 2.4.3


(hover) #11

243 version doesn’t work but 242 does.


#12

that was for future reference when a new version cones out. The wouldn’t work until a version 2.4.3 is released.


#13

Hello,

Just want to say that i have the same problem with updates, downloading manually works.

Never had issues before 2.4.2, using Gmic-QT portable for win x64 on a win7 x64 machine if it makes any difference ( tried to disable firewall, antivirus etc )

Will continue to update manually in the future if needed.

Thank you


#14

Seems fixed with 2.4.3, at least for me :slight_smile:


#15

I think that the server is backed up sometimes; e.g., the website can be slow too.


#16

It started with the release of 2.4.2 for me ( i update filters in gimp/gmic mostly after each new release ) and lasted a few days until today, plus there was no issue accessing the filters update file from the web using the direct URL, could have been a server problem but i don’t think it was this here.

Installed the 2.4.3 today and problem gone, so all good :wink: