changing size and feather of a shape on MacOSX


(peter) #1

Hi,
Manual says : “Independent of the specific shape you can scroll to change the size of the shape, shift +scroll to change the feather of the shape and ctrl+scroll to change the opacity of the shape.”
I can’t figure out how this works on MacOSX. Scrolling changes the size of the shape. CMD+scroll and Shift+scroll doesn’t seem to do anything. Can you help me out please ? Thanks.


(Mica) #2

Can you double check your hotkey settings?


(Paul Miller) #3

I just tried it on darktable 2.6.1 on macOS 10.14.3:

Shift-scroll changes the feather size (scroll up to make the feather bigger)
Cmd-scroll changes the size of the shape.
Cntrl-scroll changes the opacity (scroll up to make the shape fade)

For changing the feather size you may need to scroll quite a long way for the change to become visible.


(peter) #4

Thank you for your reply. Nothing assigned to shift, ctrl and cmd in my Mac’s hotkey settings.
@Paulmiller : that isn’t the way it sorts out on my machine.
The only thing that happens while scrolling is increase the size of the shape. No way back. Is there a way to reset the shape ? I’m stuck now with huge shapes, lol.
Anyone has a clue where to look to solve this ?


(Paul Miller) #5

You can use cntrl-z to undo changes (control-z, not command-z)

Check that ‘sticky keys’ is turned off in the Accessibility settings (Keyboard section) in the System Preferences. That usually messes things up if it gets enabled accidentally.

Other than that, I’m afraid I don’t have any more suggestions.


#6

I’ve found the same problem as you when using non-Apple devices. They work for everything except decreasing the size of the feather, where scrolling in either direction only increases the size. I have to connect an Apple wireless mouse to shift+scroll feather size in the expected way.

And as @paulmiller says, when the feather is very small, you have to scroll like crazy before you see any change of size.


(Paul Miller) #7

I just tried with a very nasty cheap non-apple mouse we had lying around the office. The results were strange.

scrolling changes the size of the shape as you would expect
control-scroll changes the opacity, as you would expect
shift-scroll only makes the feather bigger, no matter which direction you scroll in.

My Apple mouse and trackpad (two-finger scroll) both work correctly.

Which is consistent with what @archiemac observed.

Very odd.


(peter) #8

Today is another day :slight_smile: The apple-mouse shows the expected behavior : so seems to be solved after a restart. The HP-mouse I normally use for Photo-editing remains to act strange.
So lesson learned : use the Apple-mouse. Other brands may act normally : not sure what the reason could be.
Thanks everybody for looking into this. Really appreciate this community.