Characters of the interface too small

gimp

(charlie) #1

Yesterday I was suggested a good solution for Darktable, now I need another solution for Gimp 2.10.8.
The characters of the interface are too small for my eyes on my iMac 27 "(2560 x 1440).
Is there a configuration file to edit the font size?
Thank you.


(Morgan Hardwood) #2

(charlie) #3

Thank you for your kind reply but I had already tried that solution but without results. The screenshots show that the size does not change with a resolution of 2560x1440 and 1920x1080.
I’m looking for a solution similar to the one suggested for Darktable where I could increase the size of the characters in a .css file.

12

28


(Morgan Hardwood) #4

In 2019 the user experience across programs is supposed to be consistent, text sizes are supposed to match, and hand-editing configuration files is not supposed to be a thing. If you’re sure you changed the text size in macOS “the right way” and most apps now have a text size you can read but #software:darktable and #software:gimp (and #software:rawtherapee) do not, then you should file bug reports.


(charlie) #5

@Morgan_hardwood I do not think my vision problem is a software bug, so I’m looking for a personal solution.


#6

gtkrc file
font-name = “verdana 12”
https://www.flickr.com/groups/48637250@N00/discuss/72157606865430072/


(charlie) #7

Thank you, but all suggestions did not work.


(Morgan Hardwood) #8

@charlie84 I think you should re-read what I wrote as your reply was way off point.


(charlie) #9

Sorry, English is not my mother language, I understand that I should report a bug to Gimp, to Darktable, to …
I think that the small characters of the interfaces is my personal problem, not a software bug.
So I’m looking for a personal solution like the one to edit the configuration files, having already tried with negative result the setting of the monitor resolution.
I hope I explained myself.


(Morgan Hardwood) #10

@charlie84 if you set the text in macOS to a comfortable size, and most applications now use that size except for some program (RT, dt, GIMP, etc), then it is a shortcoming of that program to inherit the correct size, and so an issue should be reported so that every user of that program benefits.


(MareroQ) #11

Hi Charlie.

I do not know if you’ve tried this solution.
Unpack the attachment and place the gtkrc file directly in the home directory (where you have other files with configuration, eg gimprc, pluginrc, etc.).
In line 4, I can edit the font and its size.
Tested only in Windows.
Checked for Gimp 2.10 - but it does not work for GMIC QT (because it is not based on gtk).

gtk-theme-name = "Default"
style "user-font"
{
	font_name="Arial Bold 14"
}
widget_class "*" style "user-font"

gtkrc.zip (202 bajty)


(charlie) #12

Wonderful @MrQ,
I copied the lines of code

style “user-font”
{
font_name=“Arial Bold 14”
}
widget_class “*” style “user-font”

In the file gtkrc of my preferred theme of Gimp, and it works!
Thank you very much.