Clipped shadows, bug?, dodgy profile?, user error?... help!

printer-profile

(Andrew) #1

In summary, I can’t get the clipped shadows button to work when I have a printer profile as the output profile.

I’m trying to get some photos printed by a lab and they require the file pre-converted to their profile. So I am editing in RT and saving with their profile as the Output Profile. When I start adjusting with a curve, I notice the clipped shadows are not shown. Clipped highlights are shown. In the following I’ve set the start of the curve to a ridiculous point but still no clipping. All I have to do to see clipping is change the output profile to rtV2_sRGB and I have a very white preview.

Perhaps the profile is no good? But it’s from a pukka commercial outfit. Profile -
DC-Colour-labs-Frontier-Glossy2.icc (1.4 MB)

https://dscolourlabs.co.uk/about/NEWNEW_Technical_Support

As I move the bottom left curve point along, the histogram refuses to indicate clipping, so at least there is consistency with the preview.

I was having this issue with an old RT so have re-built tonight but it’s still there.
Version: 5.4-1297-gc75a0d6 Branch: dev Commit: c75a0d6 Commit date: 2018-12-01

Can someone maybe confirm what clipping is in relation to? Rawpedia says
“The main histogram, navigator and clipping indicators will use either the working or the output profile, depending on your setting in Preference > General.”
but there isn’t anything to set in General!


#2

Morning, @RawConvert,

You had me puzzled for a while…
But I believe that there is a very simple explanation:

In short:

The Shadow Compression slider … only has effect when the Black slider is set to a value other than 0.

See http://rawpedia.rawtherapee.com/Exposure#Shadow_Compression

Have fun!
Claes in Lund, Sweden


(Andrew) #3

hi @Claes, thanks for the suggestion. But I don’t understand it! I’m not trying to use shadow comp. I’ve just played with those sliders but they make no difference regarding display of clipped shadows. At least not on my system.


#4

Hi @RawConvert,

Oh dear, then I am afraid that I have misunderstood your question :blush:
Could you please try to re-phrase it for me? Or perhaps we could kindly ask @Morgan_Hardwood to chime in?

Have fun!
Claes in Lund, Sweden


(Andrew) #5

It boils down to : why isn’t shadow clipping revealed with this output profile? Best wishes!


#6

Hi Andrew,
It’s me again…

Screenshot_2018-12-02_21-21-20

Have fun!
Claes in Lund, Sweden


#7

Hi, @RawConvert,

Sometimes I am extremely slow – but I could not let go of your problem.
I agree with you: there is something fishy with that DC-Colour profile.

I tested with a printer profile (as output profile) that I have made myself: no problem.
Clipping is shown with the Gamut button disabled, i.e. using the gamma corrected output profile.

With your profile: problem. No clipping shown.

I believe that the best way forward for you is to file a bug report.

Sorry for being so slow :frowning:

Sincerely,
Claes in Lund, Sweden


#8

‘evenin’, @RawConvert,

I found a new clue:
I downloaded all profiles from dscolourlabs.co.uk,
and they all show the same behaviour in RawTherapee.

Have fun!
Claes in Lund, Sweden


(Andrew) #9

Thanks again @Claes, I was wondering where to go next with this, but now I’ll raise an issue, accepting of course that it might be the profile.

One thing I don’t understand though, your screen grab appears to show shadow clipping working doesn’t it?!

My screen grab had the soft-proof button pressed, it shouldn’t have been, just introducing uncertainty, in fact it doesn’t matter whether pressed or not, there is no clip indicator on my system.

Andrew


#10

Good evening, @RawConvert!

I agree, but I am not sure where you ought to complain :slight_smile:
i.e. RawTherapee or the dscolourlabs. (I bet that they will reply that
they have never ever had a complaint before.)

However: how did I manage to show shadow clipping working?
Ho-hum, I goofed. I had the gamut button pressed, which meant that
it worked on the working profile instead of on the output profile…
Evidently, that was what was nagging me & made me re-think the matter
today.

Have fun!
Claes in Lund, Sweden


(Ingo Weyrich) #11

Just to exclude… what’s the value of this at your system?

grafik


#12

Moinchen!

In my case 253/8.

/Claes


#13

@heckflosse

FWIW… the dscolourlabs’ profile reports that it is ICC version 2.4.
(The one I made myself, using Argyll, reports version 2.2.)

MfG
Claes in Lund, Schweden


(Morgan Hardwood) #14

The “clipped shadow indicator” makes pixels light up when all three channels are at or below the chosen threshold, default 8 [0-255].

The DC-Colour-labs-Frontier-Glossy2.icc has a perceptual intent and has a toe shape which prevents the green channel’s black point from falling below 15 [0-255]:

Sure enough, if I set the threshold for clipped shadows to 15 and enable clipped shadow indication, it looks like this:


(Andrew) #15

Many thanks @Morgan_Hardwood and all - Result.
It seems odd to have such a bias in favour of green but pehaps it’s all to do with the chemistry involved.
@heckflosse, thanks too, good call, I normally set lower than 8.
Glad that’s sorted!