Color Management ... ARGHHH!

Color management on Linux 22.04 with Gnome Desktop is driving me absolutely nuts! I have profiled the laptop monitor and the external monitor and installed both profiles in the Gnome settings. Colors now match nicely between the two displays…

except RawTherapee (I’m running 5.9). Within RT, it doesn’t matter how I set Settings → Color Management → Default color profile. The colors always look the same. I can even turn Use Operating System’s Main Monitor Color Profile on and off. No change.

Within digiKam, I just turned Color Management off (leaving the job to Gnome) and it’s all good. But turning it off in RT doesn’t seem to work. I am getting over saturated colors.

I used a typical photo as my desktop background and then opened digiKam and RawTherpee on top of it.

Here is my external monitor (digiKam top right, RawTherapee bottom right)

Here is the laptop monitor

Any suggestions?

– Art Z.

wayland or Xorg?


Well, that’s certainly not what should happen. However…

That’s certainly not what you should do. If you use a display profile in your system, it should be chosen in RT’s preferences as well. Either explicitly, or the automatic choice should do. Except you say it doesn’t, which is unexpected.

Unfortunately, my color setup knowledge on Linux is virtually non existant. So, I cannot be of real help…

Change the desktop environment. Gnome color management is broken


Fwiw, Gnome has always worked very well for me when running on Xorg. It seems to load the video card gamma table and announce the display color profile which software can then use for color managed views. Not sure about the Wayland session, though.

Maybe there’s not enough information about the problem and what has been done, so let’s make a guess.

But first some info about Ubuntu color management: it does work, at least in Linux Mint (wich is based on Ubuntu). However, the closest your display color gamut is to sRGB, the less changes you will see when turning on and off the display profile. So, if your display profile is close to sRGB, you won’t see huge changes when turning it off, because most probably RT defaults to sRGB (so none is the same as sRGB). A developer can prove me wrong, though.

On the other hand, according to your first screen capture:

  • you have opened a NEF file in the Editor
  • you are displaying a JPEG (I guess) file in the Main digiKam window, which I think is more or less the same as the File Browser in RT

So if I’m right, you are comparing apples to oranges: your digiKam view is from an edit coming from the original nef file, and only you know wich edits you have done to it. It happens that the very same jpeg is used as a background, so they look the same, obviously (to my knowledge, you can’t use a nef file as an OS desktop background).

AND don’t forget that by default when you edit an image in RT, on opening it there’s a profile applied to it, so there’s a bit (or a lot) of editing applied to the nef file. That means that most probably the processing applied is different in digiKam than in RT.

With the display profile set to System default or the ICC profile appropriate for your display, try to load the image in RT, apply a Neutral profile and then click the Auto-Matched Tone Curve button. I bet the colors won’t be yet the same as those from digiKam, but at least the colors shouldn’t be oversaturated (don’t forget to set the right input profile).


I opened the NEF file in RT and edited it until it looked the way I wanted it to. I saved that as a JPEG. When I open the file in anything other than RT, it looks different. They should look the same. (That’s the idea of color management, of course.)

I think that RT is misbehaving, because changing the color management settings does not change the appearance of the image.

I do not think that Gnome color management is broken. I do get different color rendition when I activate different ICC profiles in Gnome.

Rebooting fixed it. That’s a Windoze thing. I’m not supposed to need to do that with Linux :frowning:

digiKam on the left, displaying the JPEG that I created with RawTherapee.
RawTherapee on the right, displaying the NEF file as edited and after saving the JPEG.
Color management re-enabled in both programs, like it should be.

Computers hate me.


Good to hear the problem is fixed with the oldest reply from tech support “have you tried turning it off and on again” :sweat_smile:

1 Like


Yeah, and while it should be needed less often on Linux, I’ve found that if you procrastinate on rebooting after a graphics driver update (ESPECIALY an NVidia one), weird things will happen until you reboot.

Happy for you, the symptoms are exactly what I’m seeing on my imac/macos. Wish I could solve this with a reboot too!