Compile ART for Apple M1 under Monterey

I’am trying to build ART on my MacbookPro 14" (apple silicon M1Pro) under macos Monterey with no luck. Compiling run fine, with a lot of warnings, but when I launch the executable, I get only an empty window and the following error message in the console :

(ART:2446): GLib-GObject-WARNING **: 17:23:35.963: invalid cast from ‘GtkMenuBar’ to ‘GtkWindow’

(ART:2446): Gtk-CRITICAL **: 17:23:35.963: gtk_window_add_accel_group: assertion ‘GTK_IS_WINDOW (window)’ failed

If that matter I’am using homebrew to install all the dependencies.
Any help welcome.


Unfortunately I have no way of testing on a Mac, so I’m afraid you are on your own here, sorry…

Hi Alberto,
I know you are not a mac user but there are some on the forum, far more competent than me.
In any cases, thanks for ART.

After updating homebrew today, ART is working on Apple M1Pro under Monterey. The bundle doesn’t work but the script seems written for Intel version of homebrew : some paths are hard-coded to /usr/local instead of /opt/homebrew for Apple arm64.


Glad to see that it works now, so I guess last time we talked, you had not updated the homebrew librairies?

Did you try compiling ART with libraw support, and if so, how did you get libraw?

Regarding the macos bundle script, I’ve tried to modify it but it didn’t work. I’m a real noob on mac, we’ll have to hope and wait until someone knowledgeable on the new macos can make it work.

I updated the homebrew library but there was a new update yesterday and it worked with this new update. No I have not yet tried with libraw support. Wait and see …

1 Like