corlord not assigned icc - Darktable darktable-cmstest


(Martin) #1

Hi, I run Mate 16.04 and just calibrated/profiled my monitor with a Spyder4 and DisplayCAL.
It went well apart from colord wasn’t able to pick the profile in time. Solution: I installed gnome-color-manager. Then there was just a warning that I might manually assign and activate the color profile.
So I created a script #!/bin/bash dispwin /home/capponz/icc_profile/LP156WH3.icc made it executable and put that to startup.
Seems to work fine there’s just one issue wih colord. When I run darktable-cmstest

darktable-cmstest
darktable-cmstest version 2.4.1
this executable was built with colord support enabled
darktable itself was built with colord support enabled

primary CRTC is at CRTC 0
CRTC for screen 0 CRTC 1 has no mode or no output, skipping

eDP-1	the X atom and colord returned different profiles
	X atom:	_ICC_PROFILE (2530548 bytes)
		description: LP156WH3-TPS2 #1 2018-02-19 10-39 2.2 F-S XYZLUT+MTX
	colord:	"(none)"
		description: (file not found)

Better check your system setup
 - some monitors reported different profiles
You may experience inconsistent color rendition between color managed applications

I tried to fix it but am struggling. any ideas?
thanks a lot


#2

First of all, you shouldn’t mix dispwin and colord.

What exactly does g-c-m tell you when you try to assign your display profile to the monitor?


(Martin) #3

Hi houz,
thank you for your reply.
-first I tried to solve an error, not knowing that I’ll mix up something. -
(displayCAL askes you if you want to assign the profile and want it to set at startup.)
but this error appeared after the profiling/calibrating that’s why I installed gnome-color-manager
the error was
colord querying for profile returned no result for 5 secs
same here
that’s why I installed gnome-color-manager.
then the error was replaced by a warning
colord: the profile has been imported. you may need to manually assign and activate it under “color” system settings.

What exactly does g-c-m tell you when you try to assign your display profile to the monitor?

hm to be honest I’m lost here.


#4

Try doing just that. Go to the system settings to the color settings. You should be able to assign the display profile to a monitor in there. I myself don’t use GNOME so I can’t tell you what to look for exactly. Maybe others can chime in?


(Martin) #5

Unfortunately this option is no longer available in -Mate- 16.04. I’ve searched a looong time for that. thank you very much!


#6

Ah right, Mate is a fork of GNOME 2. I have honestly not the slightest clue about that. Sorry.